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KATA PENGANTAR 

Aplikasi Microsoft Office yang banyak dipakai dalam dunia kerja adalah Microsoft Excel. 

Namun, sangat disayangkan sekali, fasilitas Microsoft Excel yang sangat banyak tersebut baru 

digunakan sedikit sekali oleh penggunanya. Padahal, jika kita bisa menggunakan fasilitas 

Microsoft Excel yang lebih lanjut, maka pekerjaan rutin yang sering kita anggap membosankan 

dapat kita selesaikan dengan lebih cepat dan lebih “cerdas”. 

Modul mata bahan pelatihan untuk pemahaman analisis data dengan menggunakan Microsoft 

Excel. Dalam buku ini disajikan beberapa fitur dari Microsoft Excel yang sangat jarang sekali 

digunakan oleh penggunanya. Kebanyakan pengguna jarang menyentuh fungsi-fungsi ini 

mungkin disebabkan oleh beberapa hal, di antaranya: 

• Tidak memiliki informasi mengenai fungsi-fungsi tersebut. 

• Mengetahui fungsi tersebut, tetapi tidak mengerti maksud dan perintahnya karena 

penjelasan yang diberikan Excel menggunakan bahasa Inggris. 

• Mengetahui dan mengerti maksud fungsi tersebut, tetapi tidak pernah menggunakannya 

karena belum pernah menghadapi situasi, dimana diharuskan menggunakan fungsi 

tersebut. 

Penulis mencoba memaparkan fitur-fitur tersebut dengan cara yang paling mudah dan disertai 

contoh-contoh aplikatif agar pengguna langsung dapat menerapkan Microsoft Excel dalam 

pekerjaan sehari-hari. 
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1 PENYUSUNAN DATA DALAM EXCEL 

Penyusunan data yang baik akan memudahkan proses pengolahannya. Seringkali dijumpai 

sebuah data disusun dalam sebuah tabel yang sekaligus menjadi tabel input maupun tabel 

output. Hal ini membuat susunan tabel menjadi tidak sederhana lagi, sehingga proses 

pengolahan data menjadi terhambat akibat kompleksnya susunan tersebut. 

1.1 Tabel Yang Sederhana. 

Tabel input dan tabel output sangat spesifik sesuai kebutuhan. Tetapi, tabel data tetaplah 

sesederhana mungkin. Tabel data umumnya memiliki beberapa karakteristik, seperti:  

• Memiliki kolom (field) dan baris data (records) 

• Nama kolom bersifat unik (tidak terduplikasi) 

• Sebuah kolom hanya memiliki satu tipe data 

• Antarkolom tidak terpisah kolom kosong tanpa nama kolom 

• Nama tabel sebagai nama sheet 

• Header selalu diletakkan pada baris pertama dan hanya satu baris saja 

• Antarbaris tidak terpisah baris kosong ataupun baris subtotal 

 

Contoh: Tabel Kurs USD  

 

Gambar 1.1 Contoh Tabel Kurs USD 

 

Tabel paling sederhana sering disebut sebagai tabel normal. Antartabel sederhana 

dihubungkan oleh field utama. Umumnya, sebuah tabel yang memiliki field waktu memiliki 

hubungan dengan tabel referensi pada field utama selain waktu. Tabel referensi ini bersifat 

unique records. 

  

Contoh: Tabel Daftar Valuta  



 

Gambar 1.2 Contoh Tabel Daftar Valuta 

 

Kedua tabel di atas berhubungan melalui kode valuta, yaitu field val pada tabel kurs_usd, 

dengan field valuta pada tabel ref_valuta. Setiap tabel pada sebuah database umumnya 

disusun dengan struktur tabel normal, kemudian disusun relasi antartabel tersebut. 

1.2 Tabel Turunan 

Pengolahan data di Excel tidak sepenuhnya harus berdasar tabel normal, tetapi cukup dengan 

susunan tabel yang sederhana. Kebutuhan pengolahan data di Excel sangat spesifik berdasar 

karakteristik proses pengolahan yang dilakukan.  

Misalkan saja, data yang dibutuhkan adalah per tahun dengan pengolahan per bulan. Maka, 

data dasar untuk pengolahan disusun dalam susunan series per bulan (12 kolom bulan), 

disertai kolom rata-rata per tahunnya. Tabel dasar pengolahan adalah tabel turunan dari sebuah 

tabel normal. Susunan tabel sederhana yang dibutuhkan adalah seperti gambar berikut ini:  



 

Gambar 1.3. Tabel Pengolahan dari Daftar Valuta dan Tabel Kurs 

 

Yang perlu selalu diingat adalah kegunaan tabel turunan di atas untuk proses pengolahan data 

selanjutnya. Jika tabel turunan di atas adalah hasil akhir, maka data dasar pengolahan adalah 

tabel normal seperti tabel kurs_usd dan tabel ref_valuta. 

Teknik mengubah data dengan menggunakan rumus atau formula merupakan teknik yang 

sangat diperlukan oleh pengguna Microsoft Excel. Contohnya ada pada gambar 3.4. Daftar 

Nama Peserta Ujian, merupakan contoh data sederhana yang seluruh kolom A (Nama), berisi 

data dengan huruf kecil. Seharusnya, nama dituliskan dengan huruf besar untuk huruf awal, 

dan selanjutnya huruf kecil. Untuk mengubah agar semua huruf depan setiap kata menjadi 

huruf besar (Capital) maka kita dapat menggunakan fungsi PROPER pada Excel. 

 

 

Gambar 1.4 Daftar Nama Peserta Ujian 



1.3 Membuat Formula 

Pada kasus ini, rumus yang akan kita buat diletakkan pada kolom kosong di kolom E sebagai 

lokasi sementara. Setelah selesai, hasilnya akan menggantikan isi kolom A. 

1. Buat formula berikut di sel E2: 

 

=PROPER(A2) 

 

2. Copy formula ke bawah sesuai dengan jumlah data di kolom A.  

Dalam contoh di atas formula di-copy. sampai ke E11. Lembar kerja akan tampak 

seperti Gambar 3.5. Hasil penggunaan Proper tampak pada bagian yang disorot. 

 

Gambar 1.5 Penggunaan Proper untuk Mengubah Data 

 

1.4 Meng-copy dan Menempelkan (Paste) Sel Berisi Formula 

Pada langkah ini, formula akan di-copy dan di-paste sebagai value (paste as value), serta 

mengganti isi sel kolom A. Caranya: 

1. Pilih sel yang berisi formula, yaitu E2:E11 

2. Pilih tombol Copy atau tekan [Ctrl] + [C] 

3. Pilih sel pertama yang berisi data asli. Dalam kasus ini adalah sel A2 

4. Pilih tanda panah kecil di bawah tombol Paste 

5. Muncul pilihan seperti pada gambar 3.6  

6. Pilih 123 untuk Paste Value 

  



 

Gambar 1.6. Pilihan Paste 

 

Setelah dilakukan paste value, maka lembaran kerja akan menjadi seperti gambar 3.7.  

 

Gambar 1.7. Hasil Paste Value Dengan Hasil Fungsi Proper 

Langkah selanjutnya adalah menghapus formula yang ada di kolom E karena data tersebut 

sudah tidak diperlukan lagi. 

 



2 PROSES KONVERSI EXTERNAL DATA KE EXCEL DATABASE 

Data merupakan objek dari aplikasi Microsoft Excel. Proses input data ke dalam worksheet 

dapat dilakukan secara manual (diketik) atau menggambilnya dari data external (get external 

data). 

Import data eksternal yang dapat dilakukan oleh Microsoft Excel berupa: 

1. Import External data from Microsoft Access 

2. Import External data from web 

3. Import External data from text 

4. Import External data from other source (tidak dibahas dalam buku ini) 

5. Import External data from existing connections (tidak dibahas dalam buku ini) 

Setelah data eksternal selesai di-input, kita dapat mengolah data tersebut menjadi sebuah tabel 

yang komunikatif atau mudah dipahami dengan menggunakan menu Insert Table. Tabel 

adalah sebuah media representasi data yang terdiri dari kolom dan baris. Setiap kolom dalam 

sebuah tabel dalam Microsoft Excel biasa disebut sebagai Field.  Dalam menu Insert Table 

terdapat menu Table Tools yang dapat membantu kita dalam memodifikasi tabel sesuai dengan 

keinginan. 

Excel memiliki keterbatasan ruang data dan terkadang membutuhkan data dari aplikasi lain 

yang lebih fokus pada tata kelola data yang dibutuhkan, misalkan dari file output aplikasi lain 

yang tidak berformat Excel. Setidaknya, Excel mampu membuka dan membaca format file 

yang terdaftar saat open file. Beberapa format memerlukan proses parse melalui fitur Text To 

Columns, yang umumnya akan otomatis terbuka dan meminta untuk melakukan setting yang 

diperlukan. Hal ini akan berulang untuk file lainnya, karena sifatnya adalah mengimpor data 

tanpa adanya suatu koneksi data. 

Kebutuhan data yang rutin berasal dari sumber yang tetap -dengan isi data yang dinamis karena 

adanya proses add, delete, dan update pada sumber data- tidak dapat dipenuhi melalui open file 

atau impor data dari file output aplikasi lain. Yang dibutuhkan lebih mengarah pada adanya 

koneksitas yang kontinyu ke sumber data untuk mendapatkan perubahan data yang segera dan 

terotomasi sesuai keadaan sumber data saat itu. Untuk tujuan seperti inilah diperlukan fitur Get 

External Data yang berbasis pada suatu koneksi. 

Koneksi data umumnya dilakukan ke suatu dataset yang bisa berupa tabel (baik web table 

maupun database table) maupun views suatu database. Bahkan bisa menyusun dataset baru 

melalui suatu query. Fitur ini ada pada menu atau ribbon Data. Gambar berikut adalah tampilan 

lokasi fitur Get External Data pada Excel 2007.  



 

Gambar 2.1. Get External Data Menu 

 

Pada Excel 2003, fitur ini dikenal sebagai Import External Data dan rute pencariannya adalah 

seperti gambar berikut ini:  

 

 

Gambar 2.2.  Menu External Data pada Ms Excel 2003 

 

Perbedaan menu antara Excel 2007 dan Excel 2003 yang terjadi setelah meng-klik Data > Get 

External Data, yaitu:  



 

Gambar 2.3. Perbandingan External Data Excel 2007 dan Excel 2003 

 

2.1 Hal-Hal yang Perlu Disiapkan Untuk Melakukan Koneksi Data 

Setelah Anda memutuskan untuk melakukan koneksi data, maka hal-hal yang perlu disiapkan 

antara lain:  

1. Mengingat-ingat apakah komputer yang digunakan pernah melakukan koneksi untuk 

data yang sama  

Hal ini berkaitan dengan pemanfaatan informasi koneksi data yang telah tersimpan sebagai file 

odc, yang akan memudahkan proses koneksi ulang. File odc (Office Data Connection) berisi 

keterangan rinci tentang koneksi dan dataset yang akan diambil. Jika pernah melakukan 

koneksi dengan data yang sama, maka koneksi dilakukan dengan menggunakan odc yang sudah 

ada. 

2. Mengetahui ke mana koneksi akan dilakukan  

Anda harus tahu ke mana koneksi akan dilakukan; apakah ke aplikasi database atau web. Jika 

database, maka database berisi apa dan ada di mana. Jika dari web, url-nya (alamat website) 

apa? 

3. Mengetahui jenis koneksinya  

Anda harus mengetahui dengan pasti perintah koneksi yang dibutuhkan. Setiap database 

memiliki perintah koneksi yang berbeda, walaupun item input parameter koneksinya relatif 

sama. Perintah koneksi ini disebut Connection String. Dengan begitu, maka dapat diketahui 

apakah connection string tersebut telah masuk daftar menu Excel. Jika belum masuk, maka 

perlu penyusunan connection string baru sebagai data source baru (New Data Source). Hal ini 

membutuhkan pengetahuan tentang driver data provider dan setting yang dibutuhkan. 

Keterangan untuk ini bisa diminta pada administrator database. Kadangkala, pemilihan jenis 

driver data provider yang digunakan mempengaruhi kecepatan proses pengambilan data ketika 

terjadi multikoneksi. Penggunaan driver jenis OLEDB, secara umum, lebih cepat dibanding 

ODBC untuk memulai multikoneksi. 

4. Memahami dataset yang akan diambil  

Anda harus memahami apakah akan mengambil dataset langsung ke satu tabel/views atau Anda 

memerlukan query yang dibuat susun saat proses pembentukan koneksi, karena tidak 

tersedianya dataset yang dibutuhkan pada database sumber. 

Setelah mempersiapkan hal-hal di atas, maka langkah selanjutnya adalah memulai koneksi.  

 



2.2 Jalur Menu yang Berkaitan Dengan Properti 

Setelah data terkoneksi, maka akan ada Object Connection yang menyimpan seluruh 

keterangan koneksi. Pada Excel 2007, properti koneksi bisa diedit tanpa menggunakan VBA 

karena telah disediakan jalur menunya, yaitu melalui Data > Connections. Sedangkan, pada 

Excel 2003, pengubahan properti koneksi 2003 harus dilakukan melalui VBA. 

Satu-satunya cara untuk memuat dataset output ke worksheet adalah sebagai tabel atau pivot 

table. Saat proses refresh, Anda masih bisa mengatur data, seperti replace atau add data baru 

ketika jumlah baris berubah, autofit kolom, dan sebagainya. Pengaturan pada bentuk hasil 

berupa tabel dapat dilakukan pada properti data range, melalui:  

• Excel 2003  

o Klik cell hasil > menu Data > Import External Data  Data Range 

Properties 

• Excel 2007  

o Klik cell hasil > menu Table Tools > Design > External Data Table > 

Properties 

o Klik kanan cell hasil > Table > External Data Properties 

• Excel 2010  

o  

Setiap koneksi hanya diperuntukkan satu output. Jika output berupa tabel, maka satu koneksi 

hanya untuk satu tabel. Jika output berupa pivot table, maka satu koneksi untuk satu pivot 

cache.  

Refresh data adalah cara untuk memperbarui data, yang dilakukan melalui menu Data > 

Refresh Data. 

Setiap koneksi memiliki query yang menjadi kalimat perintah pemilihan data yang akan 

diambil. Untuk mengubah query, dapat dilakukan melalui:  

• Excel 2003  

o Klik cell hasil > menu Data > Import External Data > Edit Query 

• Excel 2007  

o Klik cell hasil > menu Table Tools > Design > External Data Table > 

Properties > tab Definition 

o Klik cell hasil > menu Data > Connections > Properties > tab Definition 

o Klik cell hasil > menu Data > Connections > Connections > pilih 

Connections > Properties > tab Definition 

Mengubah query juga dapat dilakukan melalui context menu dengan cara klik kanan cell hasil 

> Table > Edit Query. 

 

2.3 Import External Data From Microsoft Access 

Kita sering meng-import data dari Microsoft Access ke Microsoft Excel untuk berbagai 

keperluan. Tapi, kebanyakan orang tidak mempedulikan apakah datanya ter-update secara 

otomatis atau tidak. Padahal, konsistensi data itu sangat penting -misalnya jika membuat 

laporan keuangan suatu perusahaan dengan mengambil data barang yang terjual dari Access, 



kemudian di-import ke Excel. Jika tidak memperhatikan setting connectivity-nya, maka akan 

terjadi ketidak-konsistenan saat data di Access berubah, tapi di Excel tidak mengalami 

perubahan.  

Bagaimana caranya agar data Excel yang di-import dari Access bisa tetap terupdate? 

1. Buka file Excel yang sudah ada atau buat file baru jika belum ada 

2. Di tab Data, klik From Access 

 

 

Gambar 2.4 Import Data dari Ms Access dalam Excel 2010 

 

Muncul kotak dialog seperti ini. Pilih file Access yang akan di-import, lalu klik Open 

 

 

Gambar 2.5 Pilih Sumber Data dari File Ms Access 

 

4. Lalu pilih Tabel atau Query yang akan diimport, klik OK 



 

Gambar 2.6. Pilih tabel atau Query yang Ingin Diimpor 

 

5. Setelah itu, akan muncul beberapa pilihan untuk menampilkan data 

 

 

Gambar 2.7. Alternatif Penyimpanan Data yang Di-import dalam Excel 

 

Pada poin pertama, ada beberapa pilihan untuk menampilkan data, yaitu Table, 

PivotTable, dan PivotChart dan PivotTable. Anda dapat memilih sesuai dengan 

kebutuhan. 

Pada poin kedua, Anda dapat menentukan di mana Anda ingin menyimpan data, 

apakah di sheet yang sama (dengan memilih cell yang dituju) atau di sheet yang baru 

(New Worksheet), lalu tekan OK. 

 

6. Data yang Anda import akan tampil sesuai dengan keinginan.  

Jika Anda memilih dalam bentuk tabel, maka akan muncul seperti ini: 



 

Gambar 2.8. Contoh Import Data dari Ms Access dalam Bentuk table 

 

PivotTable atau PivotChart, hanya digunakan ketika Anda membutuhkan summary 

atau jumlah yang akan di group berdasarkan kriteria tertentu. 

 

7. Agar data tetap ter-update, setting Connection Properties  

Klik tanda panah di bawah tombol Refresh (tab Design ‘Table Tools’), kemudian pilih 

Connection Properties. 

 

 

Gambar 2.9 Ikon untuk Merefresh  Data Connection 

 

8. Aktifkan Refresh data when opening the file  

Jika Anda ingin data tersebut ter-update ketika membuka file, klik check box tersebut. 

Anda juga dapat meng-update setiap beberapa menit sekali dengan meng-klik check 

box Refresh every … minutes, dan mengisi kolom menit sesuai dengan keinginan. 



 

Gambar 2.10 Connection Properties 

 

9. Save file tersebut  

Ketika Anda membukanya lagi, maka data akan ter-update secara otomatis sesuai 

dengan database Access yang terkoneksi. 

 

2.4 Import External Data From Web 

1. Untuk web query, file data connection tidak dibuatkan oleh Excel, sehingga poin 

pertama yang harus disiapkan akan ada jika telah membuat file data connection web 

query yang ekstensinya .iqy. Saat ini, kita berasumsi kalau belum pernah melakukan 

koneksi ke data yang sama. 

2. Koneksi akan dilakukan ke web pages dengan url: 

http://www.seputarforex.com/berita/kurs_dollar_rupiah_hari_ini.php 

3. Jenis koneksi adalah web query melalui jalur :  

Data > Get External Data > From Web. 

4. Dataset yang digunakan adalah web tabel harga komoditas. Dataset web query yang 

bisa diambil hanya yang ada di-url tersebut apa adanya. 

5. Langkah-langkah membuat koneksi Web Query baru. 

 

http://www.seputarforex.com/berita/kurs_dollar_rupiah_hari_ini.php


2.4.1 Langkah-Langkah Membuat Web Query Untuk Excel 2003 

Klik Data > Get External Data > From Web dan akan muncul window pemilihan 

web data. 

1. Masukkan url pada address bar dan tekan GO  

Sebagai contoh, kita gunakan url berikut: 

http://www.seputarforex.com/berita/kurs_dollar_rupiah_hari_ini.php 

Tunggu hingga selesai dimuat dan menampilkan seluruh tanda tabel yang bisa diambil 

datanya pada halaman tersebut. Tanda berupa panah kecil hitam dalam kotak 

kuning. Setiap kali kursor melintasi tanda tersebut, akan tampak batas tabel untuk 

dengan tanda tersebut. 

Pemilihan tabel dapat dilakukan dengan meng-klik tanda tersebut, hingga berubah 

menjadi tanda centang. Penekanan ulang akan mengubah statusnya menjadi tidak 

terpilih atau kembali menjadi tanda panah hitam. Anda bisa memilih banyak tabel 

dalam halaman tersebut. 

Untuk langkah 1 dan 2, akan tampak seperti gambar berikut ini:  

 

 

Gambar 2.11 New Web Query 

 

2. Mengatur option (bila perlu) 

Tombol Option terletak di sudut kanan atas, dan ketika di-klik akan muncul dialog box 

seperti gambar berikut ini: 

 

http://www.seputarforex.com/berita/kurs_dollar_rupiah_hari_ini.php


 

Gambar 2.12 Web Query Options 

 

Usai mengatur, tekan tombol OK pada dialog box tersebut. Tombol Cancel untuk 

membatalkan perubahan yang sedang dilakukan. 

Item-item dalam dialog box tersebut adalah:  

o Formatting; pilih salah satu untuk mengatur format keluaran yang bisa berupa:  

▪ None  Plain teks 

▪ Rich text formatting only  Teks terformat tanpa menyertakan tag 

html seperti link dan lainnya 

▪ Full HTML formatting   Teks terformat menggunakan tag HTML 

o Import setting for preformatted <PRE> blocks; centang yang diperlukan dari 

item-item:  

▪ Import <PRE> blocks into columns untuk menjadikan tag HTML 

<PRE> jadi tanda import pada kolom baru 

▪ Treat consecutive delimiters as one untuk menjadikan karakter-

karakter delimiter yang berjejeran sebagai satu karakter delimiter saja, 

sehingga hasil import akan tetap rapat 

▪ Use the same import settings for the entire section yaitu jika ingin 

menerapkan dua setting di atasnya ke seluruh tabel yang dipilih. Jika 

tidak dicentang, maka akan diterapkan pada pilihan pertama dan sisanya 

akan dikira-kira oleh Excel. Opsi ini berlaku ketika opsi Import <PRE> 

blocks into columns dicentang. 

o Other import setting; pilih yang diperlukan saja, dan berisi:  

▪ Disable date recognition. Dalam kondisi dicentang akan mencegah 

Excel mengkonversi data yang tertulis mirip tanggal menjadi data 

datetime. Contoh, Excel akan mencegah konversi score pertandingan 

sepakbola ‘2-1’ menjadi 2 Januari atau 1 Februari, sesuai regional 

setting. 



▪ Disable web query redirections. Jika dicentang akan mencegah 

pengalihan pengambilan data dari lokasi lain. 

 

3. Menyimpan query sebagai file data connection (bila perlu)  

Koneksi transaksi hasil query akan disimpan dalam workbook. Untuk proses koneksi 

yang seluruh setting item-nya sama -meski terdapat pada workbook lain ataupun pada 

komputer lain- dapat dimudahkan dengan membuat koneksi dari file data connection 

yang ada. File ini bisa di-copy ke komputer lain. 

Caranya adalah:  

o Tekan icon Save yang ada di sudut kanan atas dekat dengan tombol option. 

o Akan muncul File Save Dialog. Kemudian beri nama file, dan ekstensinya 

biarkan tetap .iqy (internet query). 

o Pilih lokasi penyimpanan. Jika ingin query muncul dalam daftar file data 

connection secara langsung (tanpa browse), letakkan pada folder data sources, 

seperti folder MyDocuments. 

o Akhiri dengan menekan tombol Save untuk proses penyimpanan, atau tombol 

Cancel untuk membatalkan penyimpanan. 

 

4. Tekan tombol Import untuk melanjutkan ke langkah berikutnya, atau tombol Cancel 

untuk membatalkan seluruh proses 

 

5. Menentukan lokasi peletakan hasil web query 

Setelah menekan tombol Import, akan muncul dialog box Import Data yang berisi 

penentuan lokasi hasil web query, seperti gambar berikut ini: 

  

 

Gambar 2.13 Penentuan Lokasi Hasil Web Query 

 

Opsi yang dapat dipilih yaitu:  

o Existing Worksheet yang memberi keleluasaan untuk memilih cell pojok kiri 

atas pada worksheet yang sudah ada.  

o New Worksheet yang akan membuat sheet baru sebagai lokasi hasil dan 

meletakkan data hasil dengan cell A1 sebagai cell pojok kiri atasnya. 

 

6. Mengatur Properties Data Range (bila perlu)  



Bagian ini mengatur cara Excel menyusun tabel hasil, dan beberapa setting tentang 

refresh dan penyimpanan definisi query. Berikut ini adalah gambar properti data 

range untuk web query. Beberapa item ada yang berstatus disable.  

 

 

Gambar 2.14. External Data Range Properties 

 

Tekan tombol OK untuk mengonfirmasi setting properti, atau tombol Cancel untuk 

membatalkan pengubahan setting. 

 

7. Menyelesaikan proses web query 

Tekan tombol OK untuk mendapatkan hasil web query, atau tombol Cancel untuk 

membatalkannya  

Berikut ini contoh hasil dari web query untuk proses di atas: 

  

 

Gambar 2.15 Contoh Hasil Web Query 

 

 

8. Hal-hal yang berkaitan dengan hasil web query 

Hasil query memiliki beberapa hal pokok yang dapat dipakai pada penggunaan data 

berikutnya. Beberapa hal tersebut masih belum ditampilkan pada Excel 2003, sehingga 

membutuhkan VBA untuk mengubah atau mengaturnya. Hal tersebut antara lain:  



• Nama range (defined range name), yaitu nama range yang dibuat oleh Excel untuk 

memudahkan penggunaan data. Sayangnya, scope dari nama range hasil web query 

terbatas untuk sheet tersebut saja.  

 

 

Gambar 2.16 Name Range Manager 

 

• Connection melalui ribbon Data > Connections. Koneksi web query yang baru saja 

dibuat dapat diketahui melalui connection string yang tertera pada daftar koneksi. 

Umumnya, nama koneksi masih menggunakan nama generik yang memiliki kata 

'Connection'.  

 

 

Gambar 2.17 Workbook Connections 

 

Jika ada beberapa query yang menggunakan nama yang sama, maka akhir dari setiap 

nama itu ditambahkan nomor urut, seperti 'Connection_13'. Untuk mempermudah 

membedakannya, Anda bisa memberi nama koneksi sesuai dengan tema koneksi itu. 



Caranya adalah dengan memilih koneksi tersebut dan menekan tombol Properties, 

sehingga akan tampil dialog box properti koneksi sebagaimana pada gambar berikut. 

Tekan tombol OK setelah mengganti nama koneksi.  

 

 

Gambar 2.18. Connection Properties Terpilih 

 

• Mengubah data source. Hal ini dapat dilakukan pada Edit Query. Pada web query, 

edit query akan mengarahkan Anda ke window pemilihan data source seperti saat akan 

membuat baru. Anda bisa mengubahnya melalui properti koneksi pada tab definition, 

seperti gambar berikut, kemudian menekan tombol Edit Query.  



 

Gambar 2.19. Edit Query dalam Connection Properties 

 

Cara lainnya adalah melalui Context Menu. Klik kanan sebuah cell hasil web query, 

kemudian pilih Edit Query.  

 

 

Gambar 2.20. Edit Query Melalui Klik Kanan 

 

Sebuah worksheet bisa berisi banyak koneksi. Waspadai cells yang berpotongan dengan 

hasil web query, karena bisa jadi akan diperbarui oleh koneksi web query saat refresh 

data. 



2.5 Import External Data From Text 

Comma Separated Values (CVS) adalah suatu format dalam basis data, dimana 

setiap record dipisahkan dengan tanda koma (,) atau titik koma (;). Selain sederhana, format 

ini dapat dibuka dengan berbagai text-editor seperti Notepad, Wordpad, bahkan MS Excel. 

Format teks sederhana ini juga sangat baik untuk memindahkan data antarprogram yang tidak 

dapat membaca format asli masing-masing. 

Berikut langkah-langkah untuk membuka file CSV dari MS Excel 2007/2010: 

1. Buka MS Excel Anda 

2. Klik Data > Get External Data > From Text 

 

Gambar 2.21 Import from CVS 

 

3. Akan muncul Text Import Wizard, arahkan pada file .csv yang ingin Anda buka, lalu 

klik Open 

4. Setelah file terbuka, akan muncul Text Import Wizard 

5. Langkah 1: Pilih Delimited, Kemudian klik Next (Anda juga bisa juga menentukan 

baris awal data yang akan di-import) 

 

 

Gambar 2.22Text Import Wizard Dialog Langkah 1 

 

6. Langkah 2: Centang pada Tab dan Comma (atau sesuai pengaturan file Anda) 

kemudian klik Next 



 

Gambar 2.23 Text Import Wizard Dialog Langkah 2 

 

7. Langkah  3: Atur format data pada tiap kolom yang tampil dan klik Finish 

 

 

Gambar 2.24 Text Import Wizard Dialog Langkah 3 

 



3 MEMBUAT GRAFIK DENGAN SPARK-LINES OBJECT 

Grafik garis Sparkline adalah jenis grafik baru yang dihadirkan di Microsoft Excel 2010. 

Grafik jenis ini sangat berguna untuk menggambarkan perubahan data yang terjadi dalam 

rentang waktu tertentu, misalnya perubahan harga saham dari bulan Januari ke bulan Desember 

di tahun 2013. 

Grafik ini lebih mudah digunakan untuk data perubahan dalam rentang waktu tertentu karena 

akan ditampilan di sel terpisah, tepat di samping data angka dalam dokumen Excel. Namun 

begitu, grafik garis Sparkline tidak hanya digunakan untuk pergerakan saham saja. Anda dapat 

pula menggunakan grafik garis Sparkline sebagai grafik penjualan, produksi, harga, dan lain 

sebagainya.  

Untuk membuat grafik garis Sparkline di Microsoft Excel 2010, Anda dapat melakukan cara-

cara berikut:  

• Siapkan data yang akan diolah dalam dokumen Microsoft Excel 2010.  

• Pilih sel yang akan menjadi lokasi grafik, kemudian klik Insert > Sparklines > Lines. 

 

Gambar 3.1 Menu Insert Grafik SparkLine 

 

• Akan muncul menu dialog Create Sparklines di layar komputer Anda. Klik tombol di 

sebelah data range dan blok sel data, misalnya dari C8 hingga G8, kemudian klik 

tombol OK.  

• Grafik garis Sparklines telah muncul di sel tepat di kolom 8 atau sesuai lokasi yang 

Anda pilih.  



 

Gambar 3.2 Dialog Untuk Pembuatan Sparklines 

 

• Untuk sel selanjutnya, cukup klik sel grafik garis Sparklines kemudian copy dengan 

menarik dari sudut sel bertanda (+) hingga ke bagian sel yang Anda inginkan.  

 

Gambar 3.3. Tampilan Sparklines Garis 

 

 



 

 

Mengganti Warna Garis Sparklines  

• Untuk mengganti warna grafik garis Sparkline, cukup dengan memblok grafik, 

kemudian di bagian Sparkline Tools klik Design dan pada group Style Anda bisa 

memilih warna yang Anda inginkan.  

 

Gambar 3.4 Ubah Jenis Sparkline Garis dari Design Menu 

 

• Apabila Anda ingin menentukan warna yang berbeda dari group Style, Anda dapat 

mengklik Sparkline Color dan pilih warna sesuka Anda.  



 

Gambar 3.5 Ubah warna Sparkline Garis 

 

Anda dapat langsung mengubah menjadi Grafik Sparklines Bar atau Win/Loss secara 

langsung pada Menu Design. 

 



4 AUTO FILTER DAN CUSTOM FILTER 

Anda mempunyai ribuan data dan sebagian besar isinya sama (data duplikasi)? Pasti itu akan 

menyulitkan, dan membuat Anda ingin meng-generate-nya agar daftar data yang tampil di tiap 

kolom berlainan (unik). Bagaimana caranya? 

Ada dua cara yang bisa Anda lakukan. Cara pertama adalah dengan menggunakan fungsi Data 

 Autofilter, kemudian klik drop-down list untuk kolom yang diperlukan. Anda akan 

mendapatkan daftar data unik di layar. Kalau dengan cara ini Anda cukup puas, maka 

permasalahan sudah selesai. 

Jika ingin daftar data unik Anda dapat di-copy dan paste ke range (kolom) lain, maka Anda 

memerlukan cara ke dua. Untuk menghasilkan daftar yang unik tersebut, gunakan perintah 

Data  Filter  Advanced Filter. Contoh di bawah ini adalah cara untuk mendapatkan daftar 

tersebut. Kita akan menggunakan kolom B pada Gambar 6.1. 

  

Gambar 4.1 Data Awal Untuk Auto Filter 

 

Caranya adalah sebagai berikut: 

1. Klik kolom pada label huruf untuk memilih seluruh kolom yang berisi data dan copy 

dengan cara menekan [Ctrl] + [C], ke menu Edit > Copy, atau dengan menekan icon 

Copy pada toolbar standard. Anda harus memilih seluruh kolom karena seluruh isi data 

beserta judul kolomnya akan diperlukan.  

2. Paste data tersebut ke kolom lain, misalnya kolom E. Ingat, beri jarak dengan range 

sumber data. Anda juga bisa mem-paste-nya pada sheet baru. Setelah ter-paste, Anda 

masih bisa melihat garis putus-putus di sekitar kolom B, yang menunjukkan kolom B 

masih terpilih (select). Jika Anda tidak sengaja membatalkan perintah select, pastikan 

bahwa petunjuk sel (cell pointer) berada di dalam data yang baru Anda paste (kolom 

E) sebelum melanjutkan. Penting untuk Anda ketahui, Anda tidak perlu memilih 

seluruh data atau men-sort (urut data) untuk melakukan perintah ini.  

3. Arahkan kursor ke menu Data  Filter  Advanced Filter. Secara otomatis, Excel 

akan menunjukkan bahwa filtering telah aktif. Lanjutkan dengan memilih opsi Copying 



the unique records to another location, sehingga Anda dapat membandingkan kedua 

daftar secara berdampingan.  

4. Pilih opsi Copy to another location (gambar 6.2), centang di kolom Unique records 

only, dan ketik G1 pada input Copy to. 

  

 

Gambar 4.2 Select the Copy To Another Location 

 

5. Klik OK, dan Excel akan meng-copy daftar dengan data unik dari kolom sumber data 

(kolom E) ke kolom baru (kolom G). Bahkan, hasilnya akan urut abjad, seperti yang 

tampak pada Gambar 6.3  

 

Gambar 4.3 Hasil Auto Filter dengan Copy To Another Location 

http://abc-bsm.aurino.com/wp-content/uploads/2008/09/filter-and-copytoother.jpg
http://abc-bsm.aurino.com/wp-content/uploads/2008/09/hasilfiltercopyto.jpg


4.1 Filter Excel Tingkat Lanjut 

4.1.1 Mempersiapkan Data sebagai Database 

1. Baris pertama (A1:D1) adalah judul data 

2. Baris-baris berikutnya berisi data 

3. Tidak boleh ada baris yang kosong di antara data yang ada dalam database 

4. Baris kosong pada akhir data dan kolom paling kanan 

 

 

Gambar 4.4 Data Customer 

 

4.1.2 Mempersiapkan Range untuk Kriteria  

Dalam range yang Anda tetapkan untuk kriteria, masukkan aturan data yang akan ditampilkan 

apabila Anda akan mem-filter data. Anda dapat menggunakan satu atau lebih kriteria. 

1. Dalam contoh ini, sel F1:F2 adalah range untuk kriteria 

2. Judul kita letakkan pada sel F1 

3. Sel F2 berisi kriterianya  

Tanda (operator) [>] (lebih besar dari) dipergunakan bersama-sama dengan angka 500 

Setelah diaplikasikan, maka hanya pesanan yang memiliki total penjualan lebih besar dari Rp. 

500,- yang akan ditampilkan. 

Operator-operator lainnya adalah: 

< lebih kecil dari 

<= lebih kecil dan sama dengan 

>= Lebih besar dan sama dengan 

<> tidak sama dengan 

 

Gambar 4.5 Filter Condition 



 

4.1.3 Mempersiapkan Range Untuk Hasil Pengaplikasian Filter (Ekstrak Data) 

Jika Anda ingin meng-copy data ke lokasi lain, Anda harus menetapkan kolom-kolom yang 

akan anda ekstrak. Jika Anda ingin meng-copy seluruh kolom, maka Anda harus 

mengosongkan range tersebut. Caranya adalah: 

1. Pilih sel di bagian kiri atas range untuk data yang akan diambil  

2. Ketik judul untuk kolom yang ingin Anda ekstrak  

Judul harus sesuai dengan kolom judul yang sama, dalam ejaan dan tanda baca. 

Urutan kolom boleh berbeda, dan salah satu atau semua kolom dapat diikutsertakan. 

 

 

Gambar 4.6 Label Kolom 

 

4.1.4 Mengaplikasikan Filter 

1. Pilih sebuah sel dalam database 

2. Dari menu Data, pilih Filter > Advanced Filter. (Dalam Excel 2007, klik tab Data 

pada ribbon, kemudian klik Advanced Filter) 

3. Anda boleh mem-filter daftar di data asli atau copy hasilnya ke lokasi lain 

4. Excel seharusnya otomatis mendeteksi range data. Jika tidak, Anda dapat memilih sel-

sel yang akan diikutkan dari worksheet 

5. Pilih range kriteria pada worksheet 

6. Jika Anda meng-copy ke lokasi lain, maka pilih sel awal untuk menempatkan data copy 

Anda. Jika Anda menggunakan Advance Filter, dan memilih copy ke lokasi lain (copy 

to another location), maka seluruh sel di bawah range yang diekstrak akan dihapus 

7. Klik OK 

 

Penyusunan laporan sering berbentuk data terurut (sorted), baik menaik (ascending) maupun 

menurun (descending). Pada laporan yang bersumber dari data yang sudah terurut, maka akan 

data yang dihasilkan akan terurut juga. Masalah akan timbul ketika kriteria pengurutan data 

hasil di laporan bukan seperti kriteria pengurutan pada data sumber. Misalnya, laporan yang 

berupa summary berisi agregat dari data sumber akan diurutkan secara menurun berdasar nilai 

deviasi dua kolom laporan. Sedangkan, nilai deviasi adalah hasil suatu kalkulasi terhadap data 

sumber. 

Berlakunya fitur Sort pada Excel yang menuntut dilakukannya pengurutan ulang (reapply) 

merupakan proses yang dicoba untuk dihindari. Kondisi-kondisi semacam itu membutuhkan 

formula penyusunan suatu laporan yang mampu menyusun secara terurut. 

 



4.2 Perlakuan Excel Terhadap Karakter 

Sebelum melangkah lebih jauh, perlu dimaklumi bahwa Excel memperlakukan karakter secara 

case insensitive. Hal ini juga berlaku pada proses sort ataupun perbandingan karakter. Pada 

beberapa sisi, hal ini membawa keuntungan tersendiri, tetapi pada sisi lain bisa menjadi 

penghambat yang cukup serius. 

Coba perhatikan sifat karakter kosong (""), yang sering juga disebut sebagai nullstring. 

Acapkali, nullstring diperoleh dari hasil sebuah formula yang berusaha menjadikan blank 

sebagai nilai keluaran formula. Pada hakikatnya, Excel berusaha mengabaikan blank (empty), 

sehingga pada beberapa proses seperti sort, posisi blank cell selalu diletakkan pada bagian 

bawah hasil. 

Sedangkan, pada proses perbandingan, nullstring adalah sama dengan blank atau nilai default 

sebuah cell ketika belum diisi apapun. Nullstring diposisikan sebagai sebuah karakter antara 

angka 9 dan karakter ':' (titik dua). Konversi ke tipe data numerik akan menghasilkan 0 pada 

blank, dan akan menghasilkan error value #VALUE! pada nullstring. 

  

 

Gambar 4.7 Hasil Sort Ascending 

 

Gambar di atas menunjukkan hasil pengurutan menaik dari kolom sort_ascending. Nullstring 

terletak di bawah angka 7 dan di atas karakter 'A'. Blank diabaikan, sehingga terletak di paling 

bawah. Pada tabel ASCII, karakter huruf kapital memang terletak di atas karakter huruf kecil. 

Jika pada tabel di atas karakter 'A' diubah menjadi karakter 'a' dan karakter 'z' diubah menjadi 

karakter 'Z', kemudian diurutkan kembali secara menaik, maka didapatkan bahwa posisi 

karakter 'a' di atas posisi karakter 'Z'. 

 

4.2.1 Sort Dengan Formula 

Proses pengurutan data dengan fitur Sort bisa menggunakan beberapa kriteria. Namun, 

pengurutan menggunakan formula akan lebih mudah jika hanya menggunakan satu kriteria. 

Jika akan mengurutkan berdasar banyak kriteria, maka diperlukan sebuah composite key. 

Composite key bisa disusun sebagai penggabungan beberapa kolom kriteria menjadi sebuah 

kolom. Tipe data composite key diusahakan berupa numerik atau teks. 

Penggabungan kolom yang bertipe numerik pada penyusunan composite key yang bertipe teks 

harus memiliki panjang yang sama agar proses pengurutan tetap benar. Misalkan, ketika 



pengurutan menaik pada composite key bernilai {"AAA;19","AAA;123"} akan 

menghasilkan {"AAA;123","AAA;19"}, sedangkan nilai 19 mestinya lebih dulu daripada 

nilai 123. Susunan nilai-nilai composite key untuk contoh di atas akan memberi hasil urutan 

yang benar jika tersusun sebagai {"AAA;019","AAA;123"}. 

Prinsip dasar proses sort dengan formula adalah mengurutkan berdasar jumlah data setiap item 

data sumber dibandingkan item lainnya, hingga didapatkan posisi data tersebut pada data 

sumber. Jadi, yang diurutkan adalah nilai jumlah data setiap item hasil perbandingan dengan 

item lainnya. Pada data yang bersifat unik, hal ini relatif lebih mudah. 

 

4.2.2 Contoh Penyusunan Data Terurut Dengan Formula 

Gambar berikut ini adalah contoh data (kolom A) beserta hasil proses pengurutan secara 

menaik (Asc) dan menurun (Desc). 

  

 

Gambar 4.8 Sort Ascending dan Decending 

 

Data n_data dan pengali adalah cell bantu untuk memudahkan proses kalkulasi dalam 

penyusunan data terurut. Data n_data adalah jumlah record data sumber. Data pengali adalah 

cell bantu untuk menyusun data numerik terurut. 

Data numerik terurut terdiri dari jumlah data sumber yang kurang dari setiap item data sumber 

beserta posisi item tersebut dalam data sumber. Keberadaan error value #NUM! menjadi tanda 

bahwa seluruh data yang sesuai kriteria telah dimasukkan ke dalam data hasil. Cell yang 

berwarna latar biru (cell F12) adalah cell yang dijabarkan per langkah proses kalkulasi formula 

sort. Array formula yang digunakan untuk urut menaik (ascending) adalah (pada data ke-11, 

yaitu cell F12): 



 

=INDEX($A$2:$A$18,MOD(SMALL(COUNTIF($A$2:$A$18,"<"&$A$2:$A$18)*$D$2 

+ROW($A$2:$A$18)-ROW($A$1),ROW(11:11)),$D$2)) 

 

 

Untuk urut menurun (descending), cukup mengganti fungsi SMALL menjadi fungsi LARGE, 

sehingga menjadi (pada data ke-11, yaitu cell H12): 

 

=INDEX($A$2:$A$18,MOD(LARGE(COUNTIF($A$2:$A$18,"<"&$A$2:$A$18)*$D$2 

+ROW($A$2:$A$18)-ROW($A$1),ROW(11:11)),$D$2)) 

 

 

 

4.2.3 Proses Kalkulasi Formula di Cell F12 

Cell F12, berisi array formula untuk penyusunan secara menaik sebagai berikut: 

 

=INDEX($A$2:$A$18,MOD(SMALL(COUNTIF($A$2:$A$18,"<"&$A$2:$A$18)*$D$2 

+ROW($A$2:$A$18)-ROW($A$1),ROW(11:11)),$D$2)) 

 

 

Langkah-langkah proses kalkulasi di dalam formula tersebut dapat dikelompokkan dalam 3 

(tiga) tahap, yaitu:  

1. Menyusun nomor urut setiap item disertai nomor index data dan mengurutkannya (step 

1 sampai step 4) 

2. Bagian array formula yang dikerjakan pada tahap ini adalah: 

 

SMALL(COUNTIF($A$2:$A$18,"<"&$A$2:$A$18)*$D$2 

+ROW($A$2:$A$18)-ROW($A$1 

 

Tanpa ada bagian parameter data ke-k yang akan diambil pada fungsi SMALL, artinya, 

hanya sampai pada tahap mengurutkan data. Gambar berikut adalah langkah setiap 

proses pada tahap ini.  



 
 

Cell D2 adalah cell bantu yang telah dijelaskan di atas. 

 

Step 1  

Proses menyusun array jumlah item yang nilainya kurang dari masing-masing item data. 

Elemen array hasil adalah sebanyak jumlah record data. Jumlah masing-masing item dalam 

data sumber ini merupakan nomor urut data secara menaik. 

 

Step 2 dan Step 3  

Proses menyusun data numerik terurut yang telah menyimpan nomor index data. Hasil Step 1 

hanya berupa jumlah masing-masing item, tetapi letak item tersebut belum ada. Sehingga, 

ketika diurutkan, tidak dapat diketahui lagi posisi data di dalam data sumber. Hal ini akan 

menimbulkan kesulitan dalam usaha mengambil nilai data yang akan ditampilkan. 

Penggunaan fungsi Match memungkinkan untuk mengetahui posisi data, tetapi pada kasus ini 

dibutuhkan kalkulasi ulang array bagian COUNTIF($A$2:$A$18,"<"&$A$2:$A$18) untuk 

dijadikan sebagai array lookup fungsi Match. Sedangkan, bagian 

SMALL(COUNTIF($A$2:$A$18,"<"&$A$2:$A$18),ROW(11:11)) sebagai lookup value 

fungsi Match. Susunannya akan menjadi: 

 

MATCH(SMALL(COUNTIF($A$2:$A$18,"<"&$A$2:$A$18),ROW(11:11)), 

COUNTIF($A$2:$A$18,"<"&$A$2:$A$18),0) 

 

Untuk mempersedikit proses kalkulasi ulang array formula yang sama, lakukan dengan 

menyertakan nomor index posisi data pada nomor urutan yang berupa jumlah item hasil Step 

1. Cell bantu D2 adalah penyusun jumlah digit untuk wadah nomor index posisi data. Nilai cell 

bantu D2 bersifat dinamis sesuai jumlah data, sehingga setiap item pasti mendapat ruang yang 

cukup di belakang nomor urut data hasil Step 1. 

 



Penyiapan ruang dilakukan pada Step 2 dengan mengalikan hasil Step 1 dengan nilai cell 

bantu D2. Ruang yang dimaksud adalah jumlah digit di belakang nomor urut data. Kemudian, 

nomor index posisi data diletakkan pada ruang yang telah disiapkan melalui Step 2. Peletakan 

dilakukan oleh Step 3 dengan cara menjumlahkan hasil Step 2 dengan nomor index data. 

Nomor index data didapat dari nomor baris Excel data tersebut dikurangi nomor baris Excel 

header data, yaitu bagian: 

 

+ROW($A$2:$A$18)-ROW($A$1) 

 

Step 4  

Proses pengurutan dilakukan pada step ini. Fungsi SMALL digunakan untuk pengurutan 

menaik dan fungsi LARGE untuk pengurutan menurun. Perlu diperhatikan, pada step ini, 

fungsi SMALL dikalkulasi sampai tahap mengurutkan saja tanpa proses pengambilan data, 

karena tidak disertai input parameter bagian nilai ke-k. Hasil urutan berdasar nomor urut 

hasil Step 1 dan nomor index posisi data dapat diketahui pada n digit terakhir, tergantung 

jumlah angka 0 pada nilai cell bantu D2. Array terurut hasil step ini akan digunakan pada tahap 

selanjutnya. 

 

Ekstraksi Posisi Data Dari Hasil Susunan Array Terurut (Step 5 dan Step 6) 

Tahap ini adalah proses pengambilan nomor index data yang dibutuhkan. Index data didapat 

dari proses ekstraksi hasil array yang diurutkan pada tahap 1. Gambar berikut ini adalah proses 

tahap 2 pada cell F12, yang merupakan lanjutan proses tahap 1: 

  

 
 

Ekstraksi diawali dengan mengambil hasil pengurutan oleh fungsi SMALL pada tahap 1 untuk 

item array tertentu. Cell F12 adalah data hasil ke-11. Maka, akan diambil data ke-11 dari array 

hasil fungsi SMALL. 

 

Pada tahap ini, hasil bisa diletakkan pada sebuah kolom bantu. Hal ini akan mempermudah 

pengambilan data untuk banyak kolom yang merujuk pada baris yang sama. Selain itu, 

kalkulasi tahap 1 dan tahap 2 cukup dilakukan sekali. 

 

Step 5  

Proses lanjutan fungsi SMALL, yang berupa kegiatan pengambilan hasil pengurutan, 

dilakukan dengan menentukan nilai input parameter data ke-k. Karena hasil yang diambil 

untuk cell F12 adalah data ke-11, maka digunakanlah fungsi ROW dengan susunan: 

 

ROW(11:11) 



 

 

Jika bagian input parameter data ke-k ini diisi sebuah item, maka hasilnya adalah sebuah item. 

Jika diisi array numerik satu dimensi, maka hasilnya berupa array satu dimensi. Hasil berupa 

array dituliskan ke dalam cells berjumlah n item array yang sebaris atau sekolom, tergantung 

orientasi array satu dimensi yang digunakan pada bagian input parameter data ke-k. Untuk 

menghasilkan langsung seluruh item hasil pengurutan oleh fungsi SMALL, maka digunakan 

ROW(1:17). Hasil dituliskan pada 17 cells sekolom. 

 

Step 6  

Proses ini berfungsi untuk mendapatkan nomor index data. Hasil Step 5 diekstraksi berdasar 

nilai pada cell bantu D2 yang menjadi penyusun ruang untuk nomor index data. Penyusunan 

ruang dilakukan melalui proses perkalian nomor urut data dengan nilai cell bantu D2. Ruang 

nomor index data selalu berupa jumlah digit di belakang nomor urut. Jumlah digit tersebut 

adalah sejumlah angka nol pada nilai cell bantu D2. Maka, nomor index data adalah sisa bagi 

hasil Step 5 dengan nilai cell bantu D2. Fungsi untuk mengkalkulasi sisa bagi adalah fungsi 

MOD yang membutuhkan input parameter berupa nilai yang akan dibagi dan nilai pembaginya. 

Susunan formula secara garis besar adalah: 

 

MOD(formula_step5, $D$2) 

 

 

Pengambilan Nilai Data Sebagai Item Data Hasil (Step 7)  

Tahap ini berisi proses untuk mengambil nilai data sumber berdasar nomor index data. Proses 

ini bisa menggunakan fungsi OFFSET atau fungsi INDEX. Tidak tertutup kemungkinan untuk 

menggunakan fungsi yang lainnya. Kasus yang sedang kita bahas ini menggunakan fungsi 

INDEX. Nilai data sumber ada pada range A2:A8 dengan nilai index data adalah hasil Step 6. 

Susunannya secara umum adalah: 

 

=INDEX($A$2:$A$18, formula_step6) 

 

Berikut ini adalah gambar dari proses step 7.  

 

 
 

Pada laporan yang akan menampilkan banyak kolom hasil dan telah menggunakan kolom bantu 

untuk menghasilkan nilai-nilai pada Step 7, maka rujukan ke formula_step7 pada fungsi 

INDEX bisa diganti dengan merujuk ke cell bantu baris tersebut, pada kolom bantu yang berisi 

hasil Step 7. 

 



4.3 Formula Filter  

Sebuah laporan pada umumnya adalah cuplikan data tertentu berdasarkan suatu kriteria. 

Kadangkala, yang dibutuhkan dalam sebuah laporan adalah tabel hasil cuplikan yang memberi 

keleluasaan dalam memilih kriteria cuplikan data. Umumnya, bagian ini berada pada sisi 

penyusun kriteria. 

 

Penyusun kriteria bisa bervariasi tergantung luasan laporan yang bisa diperoleh dari suatu data. 

Bagian penyusunan ini umumnya berisi nilai-nilai keterangan dari kode-kode yang menjadi 

suatu dimensi data, seperti nama produk ketimbang kode produk. Tidak jarang, nilai kode-

kode suatu dimensi tetap digunakan sebagai nilai kriteria yang harus di-input oleh user untuk 

memperoleh cuplikan data, seperti kode jenis kelamin (L/P) ketimbang nilai laki-laki atau 

perempuan. 

 

Output hasil filtering umumnya diletakkan di bawah area penyusunan kriteria. Hal ini tidaklah 

mengikat, karena seluruhnya sangat tergantung kebutuhan. Adakalanya susunan kriteria perlu 

disembunyikan, misalkan, karena bersifat tetap. 

 

4.3.1 Konsep Filtering Dengan Formula 

Filtering data pada dasarnya adalah memilih data yang sesuai kriteria. Jadi, proses utamanya 

adalah membaca seluruh data pada kolom-kolom yang menjadi kriteria, kemudian 

membandingkannya dengan nilai kriteria. Jika sesuai dengan seluruh kriteria, maka record data 

tersebut akan diambil. 

Ketika bekerja dengan formula, maka yang dibentuk adalah sebuah rangkaian relasi antara data 

dengan lokasi hasil. Oleh sebab itu, yang menjadi pokok utama dalam filtering dengan formula 

adalah mendapatkan posisi atau nilai rujukan suatu kolom yang bisa mewakili masing-masing 

record yang sesuai dengan seluruh kriteria. Misalnya adalah nomor index record data, yaitu 

posisi data dalam tabel data. 

Formula yang sering digunakan adalah array formula yang berupa kombinasi fungsi SMALL 

atau LARGE dengan fungsi IF. Fungsi IF bertugas sebagai pemilah data berdasar seluruh 

kriteria, sekaligus pengambil nomor record data. Tentu saja, posisi data yang sesuai kriteria 

tidak pasti berurutan membentuk suatu sequence, malah lebih sering berlompatan dari record 

tertentu ke record lain, yang tak pasti jarak lompatnya. Fungsi SMALL atau LARGE bertugas 

sebagai penyusun data agar menjadi rapat, sehingga didapatkan output yang rapi dan padat. 

Fungsi SMALL akan menghasilkan output dari record dengan nomor index record terendah ke 

tertinggi, sedangkan fungsi LARGE adalah sebaliknya. Jadi, urutan output tetap berdasar 

urutan data, karena tidak ada proses pengurutan. 

 

4.3.2 Sebuah Kasus 

Suatu data order akan dijelajahi berdasarkan berbagai kriteria yang bersifat dinamis dalam 

penyusunan kombinasinya. Item kriteria berupa nilai data (bukan nilai kode data), sehingga 

user dapat memilih sesuai kebutuhannya. 



 

Dari penjabaran di atas, dapat ditarik kesimpulan bahwa data yang dibutuhkan adalah data 

order. Data tersebut adalah sebagai berikut: 

  

 

Gambar 4.9 Formula Filter 

 

Penyusunan bagian kriteria membutuhkan data referensi kode-kode dalam data order. Data 

referensi tersebut adalah: 

  

 

Gambar 4.10 Referensi untuk Formula Filter 

 



 

Gambar 4.11 Referensi untuk Formula Filter 2 

 

Data-data itu kemudian disusun menjadi dua bagian, yaitu bagian kriteria dan bagian result 

dari output proses filtering. Pada bagian kriteria, seluruh ruang input yang berkenaan dengan 

dimensi utama data memanfaatkan fitur Data Validation List untuk menampilkan item-item 

dimensi tersebut. Contohnya seperti dimensi Line Produksi pada gambar di bawah ini: 

  

 

Gambar 4.12 Hasil Formula Filter 

 

Data order tidak secara langsung menyimpan data item yang ada dalam pilihan di bagian 

kriteria. Oleh sebab itu, dibutuhkan proses lookup ke data referensi terkait untuk mencari 

kodenya. Hasil lookup disimpan pada kolom helper bagian kriteria. 

 

Kriteria interval quantity dan interval price, diberi Data Validation untuk menjaga agar nilai 

pada field “dari” berada pada kondisi yang lebih rendah atau sama dengan nilai pada field 



“sampai”. Field “sampai” juga diberi Data Validation agar nilainya pada kondisi yang lebih 

dari atau sama dengan nilai pada field “dari”. 

 

Bagian output filtering terletak di bagian bawah, dan juga memiliki kolom helper. Kolom 

helper bagian output berisi posisi data yang sesuai kriteria pilihan user di data order. Selain 

itu, seluruh data order akan ditampilkan ketika seluruh kriteria masih kosong. 

 

4.4 Filtering Satu Kriteria 

Agar mudah memahami konsep formula filtering, maka kita akan memulai dengan proses filter 

berdasar satu kriteria saja, dan kriteria yang lainnya diabaikan. Dalam hal ini, kriteria yang 

akan digunakan adalah kriteria warna, yang pilihannya jatuh pada warna Natural. Jadi, Anda 

telah memilih item Natural pada bagian kriteria warna di cell K9. Hasil filtering adalah sebagai 

berikut: 

  

 

Gambar 4.13 Formula Filter Array 

 

Kriteria warna Natural memiliki kode NON yang tampak pada kolom helper bagian kriteria. 

Nilai pada kolom helper inilah yang akan dijadikan nilai kriteria dalam pencarian di data order. 

Nomor index data yang sesuai kriteria didapatkan menggunakan array formula: 

 

=SMALL(IF(RIGHT($B$2:$B$9,3)=$I$9,ROW($B$2:$B$9)-ROW($B$1)),ROW(1:1)). 

 

Bagian yang di-italic adalah sisi hasil filter, baik dari bagian kriteria maupun dataset bagian 

result. 

Bagian dari array formula:  

• RIGHT($B$2:$B$9,3)=$I$9  

Proses perbandingan setiap item data order pada kolom product_id bagian warna, yaitu tiga 

karakter terkanan dari nilai data product_id, dengan nilai kriteria yang terkait secara 



langsung dengan data order, yaitu kode warna di cell I9. Hasilnya adalah array nilai TRUE 

untuk yang hasilnya benar sama, dan nilai FALSE untuk hasil perbandingan yang salah atau 

tidak sama. 

• ROW($B$2:$B$9)-ROW($B$1)  

Ini merupakan proses penyusunan nomor index data di data order. Prosesnya, nomor baris 

Excel data order tersebut dikurangi nomor baris header data order, sehingga didapat index 

record, dimulai dengan baris pertama data adalah record ber-index 1. Hasilnya adalah array 

nomor index seluruh data order. 

• IF(RIGHT($B$2:$B$9,3)=$I$9,ROW($B$2:$B$9)-ROW($B$1))  

Formula ini dipakai pada proses pengambilan nomor index data order yang sesuai kriteria. 

“Bahasa manusia” dari kalimat formula di atas adalah:  

Jika sebuah data order bagian warna dari product_id adalah sama dengan warna di bagian 

kriteria, maka akan diambil nomor index datanya. Jika tidak sesuai kriteria, maka diisi dengan 

nilai default fungsi IF pada kondisi salah, yaitu nilai FALSE. 

Untuk yang sesuai kriteria, hasilnya adalah array nilai nomor index data. Sedangkan, untuk 

yang tidak sesuai kriteria hasilnya adalah FALSE. 

•   SMALL(IF(RIGHT($B$2:$B$9,3)=$I$9,ROW($B$2:$B$9)-ROW($B$1))  

Ini merupakan proses pengurutan array hasil bagian IF yang berupa nilai-nilai nomor index 

data untuk yang sesuai kriteria, atau nilai FALSE untuk yang tidak sesuai kriteria. Pengurutan 

oleh fungsi SMALL hanya dilakukan pada data numerik dari yang terendah sampai tertinggi, 

dan nilai FALSE tidak ikut dalam proses pengurutan karena bukan data numerik. Hasil dari 

bagian ini adalah array nilai-nilai index data saja, dan telah terurut dari yang terendah sampai 

tertinggi. 

•   ROW(1:1)  

Ini adalah proses pengambilan data yang telah diurutkan oleh bagian awal dari fungsi SMALL. 

Bagian ini adalah nomor urutan ke-sekian yang akan diambil sebagai output fungsi SMALL 

secara utuh. Jika bagian ini berupa array, maka hasil fungsi SMALL akan berupa array. Jika 

bagian ini adalah nilai tunggal, maka hasil fungsi SMALL adalah nilai tunggal pada urutan 

ke-sekian sesuai nilai bagian ini. Fungsi ROW digunakan untuk menghasilkan seri angka 

berurutan dari angka 1 yang berarti data ke-1 pada bagian ini. Relatifnya range dalam fungsi 

ROW (tanpa adanya karakter $) akan membuat range rujukan dalam fungsi ROW berubah 

ketika di-copy ke baris berikutnya, dan tersusunlah urutan data yang akan diambil dari hasil 

SMALL mulai dari urutan ke-1 (terendah) sampai urutan tertinggi. Ketika nomor urut hasil 

ROW lebih banyak dari jumlah elemen array hasil fungsi SMALL bagian awal, maka hasil 

fungsi SMALL secara keseluruhan adalah error value #NUM!. 

Gambar berikut ini adalah proses kalkulasi yang terjadi pada cell I13.  



 
 

Pada cell I16, nilai Row adalah ROW(4:4), dan data ke-4 pada hasil fungsi SMALL bagian 

awal (Step 5) bernilai error value #NUM!, sehingga hasil di cell I16 adalah error value 

#NUM!. Error value ini bisa dijadikan tanda bahwa seluruh data yang harus diambil telah 

selesai diambil. 

 

Berdasarkan hasil array formula pada kolom helper, maka dapat diperoleh nilai-nilai data order 

yang menjadi output filtering karena nilai di kolom helper adalah nomor index data order 

yang sesuai kriteria. Pada proses pengambilan data, perlu pengecekan nilai kolom helper 

berdasar status isi kolom helper: apakah berupa data numerik atau bukan. Jika nilai kolom 

helper adalah data numerik, maka proses pengambilan data dapat dilakukan, misal dengan 

formula Index(Match). Penyusunan nomor urut hasil filtering juga dapat dilakukan 

berdasarkan status nilai kolom helper tersebut.  

Berikut ini adalah formula penyusunan data hasil filtering untuk kolom No dan Inv_id. Kolom 

yang lain adalah penyesuaian rujukan range data pada sisi fungsi Index.  

• Formula nomor urut: (pada cell H13) 

=IF(ISNUMBER(I13),N(H12)+1,"")  

Bagian yang di-bold adalah fungsi untuk mendapatkan nilai dari suatu cell. Karena header 

result berupa text (string), maka penjumlahan dengan angka 1 (+1) akan menghasilkan error 

value. Fungsi N akan mengambil nilai numerik dari suatu cell. Ketika cell berisi data text 

(string), maka hasil fungsi N adalah nilai 0. 

• Formula ambil data order kolom Inv_id: (pada cell J13) 

=IF(ISNUMBER($I13),INDEX(A$2:A$9,$I13),"")  

Bagian yang di-bold adalah rujukan ke kolom terkait pada data order. Untuk mendapatkan 

nilai Inv_id, maka bagian ini merujuk ke kolom Inv_id data order yang berada di kolom A 



tabel order_detail. Pengaturan absolut reference (karakter $) akan memudahkan proses peng-

copy-an formula ke cell hasil filter yang lain. Bagian yang di-italic adalah rujukan ke nilai 

kolom helper pada baris tersebut dengan referensi sisi kolom yang absolut. Hal ini akan 

menjaga agar rujukan selalu tepat ke kolom helper ketika formula di-copy ke cell hasil filter 

yang lain. 

 

4.4.1 Memberi Nilai Default Pada Kriteria yang Blank 

Ada bagian pada kriteria yang mungkin akan terisi blank. Pemberian nilai default pada bagian 

kriteria dapat dilakukan pada:  

• Formula kolom helper bagian kriteria 

• Penambahan kriteria terkait pada bagian IF array formula filtering di kolom helper 

bagian hasil filter 

 

Nilai blank dapat diartikan dengan banyak hal, di antaranya:  

1. Tidak ada hasil filter  

o Jika data order bagian yang terkait dengan kriteria tersebut tidak ada yang 

blank, maka tidak perlu ada perubahan pada formula-formula kolom helper 

di seluruh bagian. 

o Jika ada nilai blank pada data order di bagian terkait dengan kriteria dan tidak 

akan ditampilkan, maka Anda dapat memilih untuk melakukan perubahan pada:  

▪ Formula kolom helper bagian kriteria yang diubah untuk menghasilkan 

nilai tertentu yang tidak ada di data order. Misal, kriteria warna pada 

data order mungkin ada yang blank. Sedangkan, kriteria bernilai blank 

tidak akan menampilkan hasil filter. Maka, formula I9 yang awalnya 

adalah: 

 

=IF(LEN(K9),INDEX(OFFSET(dtWarna,0,-

1),MATCH(K9,dtWarna,0)),"") 

 

bagian [""] diganti suatu nilai yang tidak mungkin ada di data order, 

misalkan "XXX". 

▪ Array formula kolom helper hasil pada bagian perbandingan kriteria 

ditambahkan kriteria baru dengan memanfaatkan jumlah karakter nilai 

kriteria. Misal, pada kriteria warna, yang tidak mungkin menampilkan 

data order yang berwarna blank (karena, misalkan, ada warna blank di 

data order), maka bagian perbandingan kriteria array formula filtering 

yang awalnya: 

 

RIGHT($B$2:$B$9,3)=$I$9 

 

diubah menjadi: 

 

(RIGHT($B$2:$B$9,3)=$I$9)*(LEN($I$9)>0) 



 

yang berarti bahwa data order bagian warna sama dengan nilai kriteria 

warna, dan kriteria tidak blank. Ketika kriteria bernilai blank, maka 

seluruh hasil bagian IF akan bernilai FALSE dan hasil fungsi SMALL 

bagian awal (yang mengurutkan) akan bernilai error value #NUM! 

seluruhnya, yang berarti tidak ada hasil data. 

2. Menghasilkan data seperti difilter dengan satu kriteria tertentu  

Anda bisa memilih untuk melakukan hal ini pada:  

▪ Formula kolom helper bagian kriteria agar menghasilkan nilai tertentu. 

Misal, pada kriteria warna. Jika kriteria bernilai blank, maka setara 

dengan memfilter dengan warna coklat (brown) yang memiliki kode 

warna BRO. Pada formula cell I9 bagian [""] diganti dengan "BRO". 

▪ Formula kolom helper hasil bagian perbandingan data agar merujuk 

ke suatu nilai hasil kondisi yang jika nilai kriteria adalah blank akan 

menghasilkan nilai kriteria 'BRO', dan jika tidak blank akan 

menghasilkan nilai kriteria yang di-entry oleh user. Misal, untuk kriteria 

warna, maka bagian: 

 

RIGHT($B$2:$B$9,3)=$I$9 

 

diubah menjadi: 

 

RIGHT($B$2:$B$9,3)=IF(LEN($I$9),$I$9,"BRO") 

 

3. Mengabaikan seluruh warna yang mirip dengan status 

Pengubahan hanya bisa dilakukan pada array formula hasil bagian perbandingan 

kriteria, dengan menambah kriteria baru, memanfaatkan jumlah karakter kriteria 

dalam hubungan 'ATAU ~ OR ~ +', sehingga bagian tersebut menjadi:  

 

(RIGHT($B$2:$B$9,3)=$I$9)+(LEN($I$9)=0)  

 

sehingga ketika kriteria bernilai blank, maka bagian yang ditambahkan pasti akan 

bernilai TRUE dan dalam hubungan OR dengan tanda + akan membuat apapun hasil 

(RIGHT($B$2:$B$9,3)=$I$9) tidak akan berpengaruh. Ketika kriteria bukan blank, 

maka yang berpengaruh hanya bagian (RIGHT($B$2:$B$9,3)=$I$9). 

 

Seluruh pengubahan bagian array formula pada kasus pemberian nilai default ini termasuk 

proses filter dengan formula menggunakan banyak kriteria.  

 

4.5 Filtering Banyak Kriteria 

Untuk lebih jelasnya tentang filter berdasarkan banyak kriteria, maka contoh kasus di atas akan 

ditambah filternya berdasarkan Jenis Produk. Nilai kriteria kode jenis produk ada di cell I7. 



Bagian product_id di data order yang menunjukkan jenis produk ada pada karakter ke-3 

sampai karakter ke-5 (3 karakter). Kode jenis produk sejatinya bertipe numerik. 

 

Array formula filtering: 

 

=SMALL(IF(RIGHT($B$2:$B$9,3)=$I$9,ROW($B$2:$B$9)-ROW($B$1) 

),ROW(1:1)) 

  

diubah pada bagian RIGHT($B$2:$B$9,3)=$I$9 dengan menambahkan kriteria berdasar jenis 

produk berupa: --MID($B$2:$B$9,3,3)=$I$7. 'dan' bisa diwakili oleh karakter asterik [*], 

sehingga susunannya menjadi: 

 

(RIGHT($B$2:$B$9,3)=$I$9)*(--MID($B$2:$B$9,3,3)=$I$7) 

  

Array formula pada kolom helper bagian hasil selengkapnya akan menjadi: 

 

=SMALL(IF((RIGHT($B$2:$B$9,3)=$I$9)*(--MID($B$2:$B$9,3,3)=$I$7),ROW($B$2:$B$9)-

ROW($B$1) 

),ROW(1:1)) 

  

Penggunaan karakter [--] pada perbandingan kriteria jenis produk adalah untuk mengkonversi 

tipe data nilai bagian jenis produk dari data order hasil fungsi MID yang masih bertipe text 

(string) menjadi bertipe numerik, sehingga tipe datanya akan sama dengan tipe data nilai 

kriteria.  

 



5 METODE KONSOLIDASI. 

Konsolidasi data berguna untuk menggabungkan beberapa data dalam worksheet yang berbeda, 

yang mengandung beberapa isi yang sama. Diharapkan, konsolidasi data yang dibuat sudah 

dapat mewakili sekaligus mengetahui total dari keseluruhan data yang disusun dalam 

worksheet yang berbeda tersebut. 

Untuk memperjelas penggunaan fitur ini, kita akan mempelajari contoh kasus. Misalnya, 

seorang pengusaha toko komputer ingin mengetahui keseluruhan penjualan barang-barang dari 

ketiga cabang yang dimilikinya. Padahal, setiap kepala cabang hanya memberikan laporan 

sesuai dengan penjualan cabang yang mereka pimpin. Pengusaha tersebut harus 

menggabungkan (konsolidasi) sendiri data dari setiap kepala cabang untuk mengetahui total 

penjualan dari ketiga cabang itu. 

 

Berikut adalah susunan laporan dari ketiga kepala cabang tersebut. 

Cabang Jakarta menjual empat (4) item barang tapi tidak menjual CD-rom 

 

 

Gambar 5.1 tabel Data Kota Jakarta 

 

Cabang Bogor menjual empat (4) item barang tapi tidak menjual FlashDisk 

 

 

Gambar 5.2 tabel Data Kota Bogor 

 

Cabang Malang menjual tiga (3) item barang  

 

 

Gambar 5.3 tabel Data Kota Malang 

 



Untuk memulai melakukan konsolidasi dari ketiga data tersebut, ini langkah-langkah yang 

harus dilakukan. 

1. Masukkan semua data dari ketiga cabang tersebut ke dalam tiga worksheet yang 

berbeda, namun harus berada pada posisi sel yang sama. Supaya mudah, berikan nama 

worksheet Jakarta, Bogor, dan Malang. 

2. Buatlah data yang sama pada worksheet keempat dengan nama konsolidasi, sebagai 

tempat untuk menggabungkan ketiga worksheet sebelumnya. Kosongkan kolom 

Jumlah dan Total, karena kolom tersebut akan diisi data dari ketiga cabang yang akan 

dikonsolidasi. 

3. Seleksi kolom Jumlah dan Total (A1:D5). 

4. Pada tab Data, tepatnya pada group Data Tools, klik Consolidate. 

5. Pada bagian Function, pilih SUM karena kita akan menjumlahkan. Aktifkan opsi Top 

row, karena judul data berada di baris paling atas. 

6. Jika data yang akan dikonsolidasi berada pada workbook lain, tekan tombol Browse 

untuk mencari dan membuka workbook tersebut. Namun, kalau data yang kita perlukan 

berada di dalam satu workbook, maka tekan tombol yang berada pada kolom 

Reference, sehingga kotak dialog akan berubah bentuk. 

7. Klik tab worksheet yang bernama Jakarta, seleksi rangkaian sel A1:D5 sehingga pada 

kotak tersebut akan tertulis Jakarta1$C$1:$D$5 sebagai alamat sel yang dituju. 

8. Klik kembali tombol yang berada di sebelah kanan, untuk kembali ke kotak dialog 

Consolidate. 

9. Klik tombol Add untuk menambahkan referensi ke dalam kotak All references. 

10. Lakukan langkah yang sama (langkah 7-10) untuk memasukkan referensi dari 

worksheet yang lain, yaitu Bandung dan Semarang. Sehingga, ketiga worksheet yang 

akan dikonsolidasi telah masuk semua pada daftar All references. Ingat, sesuaikan 

dengan jumlah data. 

 

 

Gambar 5.4 Dialog Konsolidasi 

 

11. Terakhir, tekan OK. 



 

Gambar 5.5 Data Hasil Konsolidasi dari Tiga Kota 

 

 

Gambar 5.6 Data Konsolidasi Detail 



6 MENGHILANGKAN BARIS DUPLIKASI DATA 

Data double atau duplikasi data -bisa juga disebut data ganda- merupakan kesalahan dari proses 

pengisian data. Data yang sama muncul atau dimasukkan secara berulangkali oleh operator. 

Hal ini tentu sering membuat para pengolah data sakit kepala. Kesalahan data ganda ini dapat 

dicegah maupun diatasi dengan beberapa fasilitas yang ada pada Ms Excel. 

Jika data belum dimasukkan, maka Anda dapat mencegah dengan menggunakan: 

1. Data Validation (lihat: Menghilangkan Duplikasi Dalam Excel) 

Untuk mencegah entri ganda atau double dalam entri, Anda bisa menggunakan Data Validasi. 

Data Validasi dengan Allow box yang berisi “Custom” memungkinkan Anda untuk 

menuliskan formula.  

Jika Anda ingin mencegah data validasi untuk entri double, pilih range sel yang Anda ingin 

validasi, kemudian pilih Data Validasi dari menu Data. Pilih Custom dari Allow dan 

masukkan rumus berikut:  

= COUNTIF ($A$1: $A$50,A1) = 1 

Jika range berbeda, maka ubah $A$1:$A$50 sesuai dengan range yang akan divalidasi. 

Tetapi, karakter ‘$’ harus tetap disertakan sebagai referensi absolut. Contohnya seperti ini: 

 

Gambar 6.1 Display dialog Validasi 

 

2. Pemrograman VBA: 

javascript:void(0);
javascript:void(0);
javascript:void(0);


 

Gambar 6.2 VBA untuk Menghilangkan Duplikasi 

Jika data sudah dimasukkan, maka kita dapat menghilangkannya dengan cara: 

1. Program VBA (lihat: Menghilangkan Duplikasi Dalam Excel) 

2. Jika menggunkana Ms. Excel 2010, Anda bisa menghilangkan duplikasi data melalui 

perintah Data lalu klik Remove Duplicates (Ms Excel 2010). Untuk Ms. Excel 2007, 

Anda bisa memilih menu Tools lalu klik Remove Duplicates (Ms Excel 2007) 

Misal, kita memiliki data sebagai berikut: 

Tabel 6-1: Tabel Untuk Data Duplikasi 

Nama Departemen Tugas 

Amir Pemasaran Senin  

Andi Personalia Selasa  

Keke Pemasaran Rabu  

Dika Produksi Kamis  

Amira Personalia Jumat  

Sofia Personalia Sabtu  

Keke Pemasaran Minggu  

Dika Produksi Senin  

Bambang Produksi Selasa  

Bagus Produksi Rabu  

Zahid Pemasaran Kamis  

Charlie Pemasaran Jumat  

Andi Personalia Sabtu  

 Cara untuk menghilangkan duplikasinya adalah: 

1. Pilih atau blok range data yang akan Anda hilangkan duplikasi datanya 

2. Setelah itu klik tab Data lalu klik tombol Remove Duplicates 



 

Gambar 6.3 Icon Remove Duplicate pada Menu Data 

3. Kemudian akan muncul kotak dialog Remove Duplicates 

 

Gambar 6.4  Dialog Remove Duplicates untuk Memilih Field Duplikasi 

Ada beberapa pilihan, apakah akan menghapus berdasarkan kriteria kolom tertentu saja 

atau hapus berdasarkan kriteria semua kolom. Jika ingin menghapus hanya berdasarkan 

kolom Nama saja, Anda dapat menghilangkan tanda checklist () pada kolom 

Departemen dan kolom Tugas.  

4. Selanjutnya klik  

  

 

Gambar 6.5. Pesan Hasil Penghapusan Duplikasi 

Hasil data yang double atau ganda berdasarkan Nama akan dihapus, tanpa kita harus memilih 

satu persatu. 



 

 

Gambar 6.6 Hasil Setelah Remove Duplicates 

 



7 DATA ENTRY FORM - EXCEL BUILT-IN  

If your spreadsheet is too big to manage, and you constantly have to scroll back and forward 

just to enter data, then a Data Form could make your life easier. To see what a Data Form is, 

we’ll construct a simple spreadsheet  

• Enter January in Cell A1 of a new spreadsheet  

 

• AutoFill the rest of the months to December  

 

• Now, highlight the columns A1 to L1 (click on the letter A and drag to letter L)  

•  

•  

• On the Home menu from Excel 2007, locate the Cells panel  

• On the Cells panel, click the Format item  

• From the Format menu, click Width  

• Enter a value of say 20 for the Column Width, and click OK  

• Some of your months should disappear from the spreadsheet  

• The problem is, if you have to enter data under each month, you’d have to scroll across to 

complete the row. And then scroll back again to start a new row. Instead of doing this, we’ll 

create a Data Form. You then enter data in the form to complete a row on your spreadsheet. 

No more scrolling back and forth! Type any number you like in cell A2, under January. 

Then type a number in cell B2 for February. Now highlight the columns A to L again. This 

is so that Excel 2007 will know which are the column headings and which is the data.  

• Click the Form item you have just added to the Quick Access toolbar:  

2007 menu or 2010 menu  

• You should then see this:  

javascript:void(0);


 

Just continue your data entry by filling the data and add new data in new line using 

button.  

If you have existing records, you will see a form for each record. If your spreadsheet is new, 

you’ll see a blank form with your labels.  

While the Excel data form may not make data entry fun, it does reduce the time it takes me to 

enter the data. 

 



8 MEMBUAT DAFTAR DROP-DOWN DALAM SEL 

Drop Down list di Ms Excel merupakan suatu daftar pilihan, dimana Anda dapat memilih salah 

satu pilihan untuk mengisi suatu data tertentu dengan cara meng-klik tombol Dropdown pada 

sebuah sel. Hal ini akan memudahkan pengguna untuk mengisi sebuah data yang pilihan 

isiannya sudah ditentukan, contohnya ya atau tidak, pilihan bulan Januari sampai Desember, 

atau pilihan berdasarkan kategori waktu tertentu, dan sebagainya. 

Untuk membuat drop down list di Ms Excel, Anda bisa mengiikuti cara-cara berikut: 

Misalnya, Anda akan membuat drop down list berupa Bulan dalam satu tahun. 

1. Klik sel yang akan Anda gunakan untuk membuat drop down list. Anda bisa langsung 

menyeleksi atau mem-blok beberapa sel. 

 

 

Gambar 8.1 Tampilan Data Drop Down Sederhana 

 

2. Buatlah daftar Bulan dalam satu tahun mulai Januari sampai dengan Desember. 

3. Pada ribbon Data, pilih group menu Data Tools kemudian klik Data Validation. 

 

 

Gambar 8.2 Menu Data Validation 

 

4. Pada jendela Data Validation, klik tab Setting. Kemudian, pada pilihan Allow pilih 

List. 



 

Gambar 8.3 Pilihan Kriteria Validasi 

 

5. Klik pada isian di Source kemudian blok daftar bulan yang telah Anda buat tadi. 

 

 

Gambar 8.4 Isi Range Data Lookup/Database 

 

6. Anda bisa membiarkan check box Ignore Blank dalam keadaan kosong, dan bisa 

memilih opsi peringatan dan pesan jika memasukkan data yang tidak sesuai pada tab 

Error Alert. Jadi, jika Anda memasukkan data yang salah, akan muncul pesan yang 

telah Anda buat sebelumnya, misal “masukkan data yang telah ditentukan dengan 

memilih salah satu”. 



 

Gambar 8.5 Pengaturan Pesan Dalam Validasi Data 

 

7. Jika semua pengaturan dirasa telah cukup, klik OK 

 

Mulai sekarang, jika sel tersebut dipilih, maka akan muncul tanda dropdown di sebelah kanan 

dari sel tersebut. Dengan klik tanda dropdown tersebut, akan muncul pilihan yang telah dibuat 

dan Anda tinggal memilih salah-satu pilihan yang ada. 

 

 

Gambar 8.6 Hasil Data Validasi 

 

Agar tampilan data lebih enak dilihat, sebaiknya daftar bulan yang telah diketik di awal (nomor 

satu) diletakkan pada sel yang berada di luar tabel atau tampilan data, kemudian ubah warnanya 

menjadi putih sehingga tidak terlihat adanya daftar pilihan di lembar kerja tersebut. Atau, bisa 

juga daftar pilihan diletakkan pada worksheet lain. 

 



9 FUNGSI LOOKUP 

Me-lookup data termasuk kegiatan yang sering kita lakukan. Karena itu, Excel menyediakan 

group fungsi LookUp & Reference. Fungsi yang sering digunakan antara lain VLookUp atau 

HLookUp, LookUp, kombinasi Offset dengan Match, dan kombinasi Index dengan Match. 

Sebenarnya, masih banyak kombinasi beberapa fungsi yang bisa kita gunakan dalam kegiatan 

lookup, tetapi pembahasan akan dibatasi pada fundamental kegiatan lookup itu sendiri, 

sehingga dapat menyusun kombinasi beberapa fungsi untuk kegiatan lookup. Beberapa hal 

yang perlu diingat adalah:  

• Kegiatan lookup secara exact pada data yang tidak unique akan menghasilkan data yang 

pertama kali ditemui. 

• Kegiatan lookup secara approximate menuntut data yang terurut sesuai karakteristik 

fungsi yang digunakan. Jika tidak terurut, maka sangat mungkin untuk mendapatkan 

kesalahan pada hasil.  

 

9.1 Fungsi VLookUp atau HLookUp 

Kedua fungsi ini hanya berbeda pada orientasi susunan data. Fungsi VLookUp menggunakan 

data berorientasi vertikal atau record yang tersusun dalam baris. Fungsi HLookUp 

menggunakan data berorientasi horisontal atau record yang tersusun dalam kolom. Kedua 

fungsi ini membutuhkan kolom nilai yang di-lookup pada field pertama (teratas untuk 

VLookUp atau terkiri untuk HLookUp), sehingga penggunaannya terbatas pada lookup ke 

kanan atau ke bawah saja. Data hasil lookup diletakkan mulai field pertama sampai field ke-n 

sesuai kebutuhan. Kedua fungsi membutuhkan nomor index field yang akan menjadi kolom 

atau baris output dan bersifat case insensitive. 

 

9.2 Fungsi LookUp 

Penyertaan kolom atau baris hasil hanya terdiri dari satu kolom atau satu baris saja. Jadi, fungsi 

LookUp bisa digunakan untuk me-lookup ke arah kiri (atas) ataupun kanan (bawah). 

Karakteristik utamanya adalah selalu mencari yang sama atau yang tertinggi dari data lookup, 

yang kurang dari nilai lookup. Artinya, sangat dianjurkan untuk menyusun data lookup yang 

terurut menaik untuk mendapatkan ketepatan hasil kalkulasi. 

 

9.3 Formula Kombinasi Fungsi Offset dengan Match 

Fungsi Offset merujuk pada sebuah cell yang menjadi patokan. Fungsi Match digunakan untuk 

mencari nilai geserannya. Jadi, fungsi Match bisa digunakan pada sisi rows atau cols sesuai 

kebutuhan. Kegiatan lookup dilakukan oleh fungsi Match, sedangkan fungsi Offset adalah 

untuk mengambil data hasil lookup. 



9.4 Formula Kombinasi Fungsi Index dengan Match 

Fungsi Index merujuk pada suatu range yang merupakan hasil lookup. Hasil lookup ditentukan 

oleh fungsi Match yang menghasilkan nomor index data pada array untuk Match. Jadi, fungsi 

Match digunakan untuk mendapatkan posisi hasil pada referensi fungsi Index. Fungsi Index 

menghasilkan output berupa range perpotongan antara baris dan kolom. 

 

9.5 Lookup Data yang Sama Persis (Exact) 

Data yang menjadi contoh pertama adalah seperti gambar di bawah ini. Data ini bersifat unique 

records. 

  

 

Gambar 9.1 Lookup Data Sama 

 

Contoh masalah berdasar data di atas adalah:  

1. Kapan pesanan customer 3 terkirim? 

2. Berapa nomor invoice customer 4? 

3. Customer berapa yang qty-nya tertinggi? 

 

Berikut solusi untuk masalah lookup di atas:  

 

 

Gambar 9.2. Contoh Rumus dan Hasil Lookup 

 



1. Kapan pesanan customer 3 terkirim? 

Field lookup value ada di kolom B. Field hasil lookup ada di kolom F. Jenisnya lookup ke 

kanan. Jadi, fungsi VLookUp bisa digunakan. 

a) VLookUp membutuhkan lookup_array dari kolom B sampai kolom F 

(B2:F5). Index_col kolom hasil (kolom F) dari kolom B yang ber-index_col = 

1 adalah 5. Tipe pencariannya adalah exact match (FALSE). 

b) Index(Match) tersusun dari fungsi Match sebagai inti kegiatan lookup, dan 

fungsi Index untuk mengambil hasil output. Oleh sebab itu, fungsi Index diberi 

referensi kolom F (kolom hasil). Fungsi Match membutuhkan kolom B 

(lookup_array) untuk mencari nilai lookup (3) dengan tipe pencarian adalah 

exact (0). Fungsi Match diletakkan pada sisi row_number dari fungsi Index 

karena orientasi data yang vertikal. 

c) Offset adalah fungsi lain untuk mengambil hasil lookup. Kegiatan lookup tetap 

menggunakan fungsi Match. Fungsi Offset di sini merujuk ke cell header kolom 

lookup_value. Kolom hasil adalah geseran (offset) empat kolom ke kanan (+). 

Geseran barisnya adalah sebanyak hasil fungsi Match. 

d) LookUp membutuhkan array hasil komparasi nilai-nilai kolom lookup (kolom 

B) dengan nilai lookup yang harus sama. Hasil dari komparasi ini adalah nilai 

TRUE atau FALSE, sehingga lookup_value yang digunakan oleh fungsi 

LookUp adalah nilai TRUE. Kolom hasil adalah kolom F. 

 

2. Berapa nomor invoice customer 4? 

Field lookup value ada di kolom B. Field hasil lookup ada di kolom A. Jenisnya lookup 

ke kiri. Jadi, fungsi VLookUp tidak bisa digunakan. Seluruh susunan memiliki 

kemiripan dengan soal nomor 1, kecuali nama kolomnya. 

 

3. Customer berapa yang qty-nya tertinggi? 

Field lookup value ada di kolom E. Nilai lookup adalah nilai maksimum kolom E, 

sehingga membutuhkan fungsi Max untuk menentukannya. Field hasil lookup ada di 

kolom B. Jenisnya lookup ke kiri. Jadi, fungsi VLookUp tidak bisa digunakan. 

Perbedaan dengan soal nomor 2 adalah pada sisi penentuan nilai lookup yang 

merupakan hasil kalkulasi sebuah fungsi, dalam hal ini berupa fungsi Max. 

 

9.6 Lookup Pada Referensi Berupa Interval Nilai (Approximate) 

Berikut ini adalah data untuk contoh lookup yang berjenis approximate. Data bersifat unique 

records dan terurut menaik (ascending) pada kolom usia anak dan baris usia pengabdian. Usia 

pada data referensi adalah batas bawah suatu interval. Misalnya, data usia 0 adalah batas bawah 

dari interval usia 0 sampai kurang dari 3 tahun (0 >= usia < 3).  



 

Gambar 9.3 Data Lookup untuk Interval 

 

Masalah yang akan dibahas adalah:  

Berapa tunjangan untuk anak yang didapatkan seorang pegawai yang telah bekerja selama 12 

tahun dan memiliki anak berumur 8 tahun? 

Pada data yang terurut menaik, beberapa solusi yang mungkin adalah seperti gambar berikut 

ini:  

 

 

Gambar 9.4. Rumus dan Hasil Lookup Interval 

 

Fungsi Match memiliki kemampuan untuk melakukan kegiatan lookup pada data yang terurut 

menurun (descending), yaitu dengan input parameter match_type bernilai -1. 

Pada kasus ini, kegiatan lookup dilakukan dua kali, yaitu terhadap:  

1. Kolom usia anak untuk mendapatkan posisi baris data yang sesuai kriteria usia anak. 

2. Kolom usia pengabdian untuk mendapatkan posisi kolom data yang sesuai kriteria 

pengabdian. 

Perpotongan kedua hasil lookup tersebut, menunjukkan nilai hasilnya. 

 

VLookUp digunakan dengan susunan:  

• Nilai lookup_value adalah usia anak yang ditanyakan, yaitu 8. 

• Data rujukan pencarian adalah kolom usia anak (kolom A), sehingga table_array 

adalah seluruh data mulai dari kolom A sampai kolom G, yaitu A2:G12. 



• Nilai col_index harus dicari dengan kegiatan lookup menggunakan fungsi Match. 

Susunan fungsi Match adalah:  

o Nilai lookup_value berupa nilai pengabdian, yaitu 12. 

o Kegiatan lookup dilakukan pada seluruh header (A1:G1), karena fungsi 

VLookUp membutuhkan table_array dari kolom A. 

o Cara pencarian fungsi Match adalah approximate (nilai tertinggi yang kurang 

dari atau sama dengan lookup_value) dengan match_type diberi nilai 1. 

• Cara pencarian fungsi VLookUp adalah approximate, yaitu mengisi input parameter 

range_lookup dengan nilai TRUE. 

 

Index(Match) dapat digunakan dengan susunan sebagai berikut:  

• Fungsi Index diberi rujukan array hasil berupa seluruh range data selain kolom usia 

anak, yaitu range B2:G12. 

• Bagian row_num pada fungsi Index didapat melalui kegiatan lookup menggunakan 

fungsi Match terhadap data usia anak (A2:A12) berdasar nilai usia anak yang dicari, 

yaitu 8, dengan match_type bernilai 1. 

• Bagian col_num pada fungsi Index didapat melalui kegiatan lookup menggunakan 

fungsi Match terhadap header yang merupakan nilai-nilai pengabdian (B1:G1) berdasar 

nilai pengabdian, yaitu 12, dengan match_type bernilai 1. 

 

Offset digunakan bersama fungsi Match untuk memperoleh nilai geseran (offsetting) sisi row 

dan col. Susunan fungsi Match adalah seperti pada Index(Match). Patokan (anchor) dari 

fungsi Offset diset pada cell sebelum data pertama usia anak dan sebelum data pertama 

pengabdian, yaitu cell A1. 

 

LookUp lebih mirip seperti VLookUp. Fungsi ini selalu bekerja dengan array satu dimensi. 

Susunannya adalah sebagai berikut:  

• Nilai lookup adalah usia anak, yaitu 8. 

• Data pencarian (array lookup) adalah kolom usia anak, yaitu range A2:A12 yang 

menjadi nilai input parameter lookup_vector. 

• Data hasil lookup (array hasil) ditentukan dengan memanfaatkan fungsi Offset dan 

Match, seperti cara Offset di atas, dengan nilai input parameter row adalah 0. 

 

 



10 VLOOKUP, DATA VALIDATION DAN CONDITIONAL FORMATING  

Pada bagian ini, kita akan menggunakan contoh kasus. 

Misalnya, kita ingin memberikan kriteria warna pada nama-nama kota yang telah diketahui 

kriteria wilayahnya, supaya setiap wilayah dapat langsung mengetahui KPW dan warna 

wilayahnya dan tidak perlu menghafalkan secara manual lagi. Apa rumus yang tepat untuk kita 

gunakan? 

 

KODE Wilayah NAMA WILAYAH KPW KODE WARNA 

1 BALARAJA BTN MERAH 

2 BOGOR JBA BIRU 

3 CAKUNG JBT HIJAU 

4 Depok DPK UNGU 

 

Untuk menyelesaikan permasalahan ini, kita dapat menggunakan VLookUp, Conditional 

Formatting, dan Data Validation untuk memasukkan datanya. 

Mari kita susun data sebagaimana yang kita kehendaki: 

Susunan data dari A1 sampai D5 sebagai berikut: 

 

Gambar 10.1 Data Referensi Lookup 

 

Kemudian kita buat sel dengan isi teks “Nama Wilayah” misalnya pada sel E7, dan pada sel 

F7 kita gunakan Data Validation untuk memasukkan data Nama Wilayah yang akan dicari 

(lihat Memvalidasi Entri Text dalam Excel 2010). 

Pada sel E8 kita masukan judul “KPW”, sedangkan pada sel F8 kita masukkan rumus: 

=VLOOKUP(F7,$B$1:$D$5,2,FALSE). 

Pada sel E9 kita masukan judul “Warna”, sedangkan pada sel F9 kita masukkan rumus: 

=VLOOKUP(F7,$B$1:$D$5,3,FALSE).  



Agar warna berubah sesuai dengan yang kita kehendaki, kita gunakan Conditional 

Formatting pada sel F9 seperti pada gambar 12.1. Hasilnya dapat dilihat pada gambar 12.2. 

a  

Gambar 10.2 Hasil Dan Keterangan 

 

Gambar 10.3 Conditioonal Formating setting 



11 FUNGSI LOOKUP LANJUT 

Kegiatan lookup memiliki empat komponen utama, yaitu: 

1. Nilai yang akan di-lookup (lookup_value) 

2. Data atau referensi pencarian nilai yang di-lookup (lookup_array) 

3. Cara pencariannya (sama persis ~ exact ~ atau pendekatan ~ approximate ~ ) 

4. Data atau referensi hasil output (result_array) 

Susunan nomor 2 dan nomor 3 akan mempengaruhi cara penyusunan formula. 

 

11.1 Lookup Banyak Kriteria Secara Exact 

Data yang akan kita gunakan adalah sebuah laporan. Hal ini memang kurang memenuhi sifat 

ke-database-an, tetapi sangat sering terjadi. 

 

 

Gambar 11.1 Data Lookup Kriteria Banyak 

 

Permasalahan yang menggunakan data tersebut adalah: 

 

 

Gambar 11.2 Rumus Lookup Kriteria Banyak 



Langkah pertama adalah penjabaran masalah. Hasil penjabarannya sebagai berikut: 

1. Nilai yang akan di-lookup (lookup_value) 

o Bagian pencarian pada sisi baris: 

Baris data yang diambil adalah berdasar kriteria Tanggal dan Lokasi yang 

sesuai. 

o Bagian pencarian pada sisi kolom: 

Kolom data yang diambil adalah berdasar kriteria Level dan Shift (Siang atau 

Malam) yang sesuai. 

2. Data atau referensi pencarian nilai yang di-lookup (lookup_array) 

3. Nilai yang di-lookup adalah sesuai atau tidak sesuai, maka disusunlah seluruh kondisi 

berdasar kriteria yang menghasilkan pernyataan sesuai atau tidak sesuai. 

o Bagian pencarian pada sisi baris: 

Susunannya adalah (A3:A11=C15)*(B3:B11=C16) yang menghasilkan 1 

(sesuai) atau 0 (tidak sesuai). 

o Bagian pencarian pada sisi kolom : 

Susunan untuk Malam adalah (C1:E1=C17)*(D2:F2=C18) yang menghasilkan 

1 (sesuai) atau 0 (tidak sesuai). Untuk Siang susunannya adalah 

(C1:E1=C17)*(C2:E2=C18). Hal ini disebabkan oleh susunan level yang 

hanya memiliki angka pada shift siang saja. Bagi kita, semua terlihat baik-baik 

saja dan jelas bahwa baik shift siang maupun malam memiliki level yang sama 

sesuai nilai level di atas nilai shift tersebut. Bagi komputer, shift malam tidak 

memiliki nilai level. Maka alangkah baiknya jika ada baris bantu yang 

berisi nilai level untuk seluruh item shift. 

4. Cara pencariannya (sama persis ~ exact ~ atau pendekatan ~ approximate ~ ) 

5. Nilai yang di-lookup hanya ada dua kemungkinan, yaitu sesuai atau tidak sesuai, maka 

tipe pencariannya adalah sama persis (exact). 

6. Data atau referensi hasil output (result_array) 

7. Hasil selalu mengikuti posisi shift sebagai header terlengkap. Karena range berdasar 

shift adalah D2:F2, maka hasil output adalah seluruh data dari kolom D sampai kolom 

F, yaitu D3:F11. 

Formula dapat disusun berupa array formula, karena ada bagian yang membutuhkan kerja 

array, yaitu komputasi berdasar beberapa kriteria. Fungsi Index dapat digunakan untuk 

menghasilkan output. Fungsi Match sebagai proses lookup. Bagian row_num dan col_num 

pada fungsi Index akan berupa array formula fungsi Match yang bersesuaian, yaitu bagian 

pencari baris pada sisi row_num dan bagian pencari kolom pada sisi col_num. 

 

Ketika memanfaatkan baris bantu untuk susunan Level, maka akan tampak seperti gambar di 

bawah ini: 



 

Gambar 11.3 Hasil Lookup Dengan Kriteria Banyak 

 

Formula bagian berdasar kriteria Level dan Shift berubah menjadi lebih universal. Rujukan 

yang dibandingkan melalui fungsi Match adalah seluruh kolom header. Rujukan untuk fungsi 

Index juga disesuaikan menjadi seluruh kolom data. 

 

Pada contoh di atas, seluruh tanggal bersifat unique. Formula tetap berlaku meskipun tanggal 

tidak unique, tetapi secara keseluruhan (kombinasi tanggal dan lokasi) tetaplah unique. 

 

11.2 Lookup Banyak Kriteria dengan Referensi Berupa Interval Kelas 

(Group) 

Proses lookup dengan data referensi lookup yang berisi interval kelas (group) selalu terurut. 

Setidaknya berdasar sebuah field utama yang menentukan tata urutan interval kelas. Misalnya, 

field waktu menjadi penentu tata urutan interval kelas. 

Tabel di bawah ini adalah data snapshot dari data job_schedule pada periode bulan Juni.  



 

Gambar 11.4 Data Job schedule Juni 2010 

 

Field Tanggal pada kasus ini menunjukkan tanggal dimulainya tugas Supervisor. Masa tugas 

Supervisor adalah sampai masa pergantian kepada Supervisor lainnya di tanggal tertentu 

sesudahnya. Masa tugas setiap Supervisor berbeda-beda, tergantung Lokasi dan Level 

pekerjaan, selain tergantung Golongan si Supervisor itu sendiri. Maka, dapat disimpulkan 

bahwa field Tanggal adalah nilai-nilai batas bawah dari suatu interval masa kerja 

seorang Supervisor. Misalnya record ke-1 (baris 2 Excel), Supervisor Aaa mulai bertugas dari 

tanggal 01-06-2010 sampai tanggal 05-06-2010. Pada tanggal 06-06-2010, si Aaa akan 

digantikan oleh si Ddd (record ke-6 ~ baris 7 Excel). 

Data memiliki fields kunci yang unique, dengan tata pengurutan interval kelas berdasar field 

Tanggal. Fields kunci data di atas adalah field Tanggal, Lokasi, Level, dan Shift. Field 

Supervisor adalah sebuah field property. Tabel tersusun sederhana memenuhi kaidah database 

(tabel normal). 

Pada contoh kasus ini, akan tampak pengolahan yang relatif lebih mudah dibandingkan dengan 

penggunaan data dalam bentuk report seperti contoh kasus yang sebelumnya. Permasalahan 

yang menggunakan data tersebut adalah sebagai berikut:  



 

Gambar 11.5 Hasil dan Rumus Penerapan Lookup dalam Job Scheduling 

 

Nilai kriteria untuk field Lokasi, Level, dan Shift adalah exact, tetapi nilai kriteria field Tanggal 

adalah pendekatan (approximate). Maka, yang perlu diketahui adalah interval kelas untuk 

kriteria tanggal tersebut (10-06-2010) yang ke-unique-annya dipengaruhi oleh field utama 

lainnya, yaitu field Lokasi, Level, dan Shift. Dengan diketahuinya interval kelas pada kriteria 

tersebut, maka dapat diketahui Supervisor penanggungjawabnya. 

Contoh solusi yang digunakan adalah array formula Index(Match) untuk memudahkan 

pemahaman konsepnya. Bagian Index untuk mengambil nilai output sesuai permasalahan, dan 

bagian Match untuk kegiatan lookup sesuai kriteria yang ada. Susunan input parameter pada 

formula Index(Match) adalah:  

• Referensi untuk fungsi Index adalah data hasil, yaitu kolom Supervisor (E2:E13) 

• Nilai lookup untuk fungsi Match adalah nilai kriteria Tanggal, yaitu 10-06-2010 (cell 

C17) 

• Kondisi selain interval kelas adalah kesesuaian antara data dan kriteria untuk fields 

Lokasi, Level, dan Shift yang harus terpenuhi seluruhnya. Susunan kondisinya adalah 

(B2:B13=C18)*(C2:C13=C19)*(D2:D13=C20) 

• Array data batas bawah interval kelas adalah data Tanggal yang seusai antara data dan 

kriteria pada field Lokasi, Level, dan Shift. Oleh sebab itu digunakan fungsi IF sebagai 

pemilih data Tanggal, sehingga untuk kondisi yang tidak sesuai, nilai item array batas 

bawah interval kelas akan diisi dengan nilai yang tipe datanya tidak sama dengan tipe 

data tanggal. Penggunaan nilai default fungsi IF pada kondisi salah, yaitu nilai boolean 

FALSE, adalah upaya untuk membedakan dengan tipe data untuk record yang sesuai 

(tipe data datetime pada kolom Tanggal). Susunan array lookup untuk fungsi Match 

adalah IF( (B2:B13=C18)*(C2:C13=C19)*(D2:D13=C20) , A2:A13) 

• Nilai untuk input parameter match_type pada fungsi Match adalah 1 (satu), karena data 

terurut menaik (ascending) pada kolom Tanggal yang berisi nilai-nilai batas bawah 

interval kelas. 

Susunan array formula Index(Match) secara utuh menjadi: 



=INDEX(E2:E13,MATCH(C17,IF((B2:B13=C18)*(C2:C13=C19)*(D2:D13=C20),

A2:A13),1)) 

 



12 MEMBUAT DAN MENGGUNAKAN PIVOT TABLE  

Pivot table adalah perangkat khusus di Microsoft Excel yang berfungsi untuk memberikan 

perspektif terhadap data yang kita miliki. Pivot table memungkinkan kita untuk membuat 

tampilan interaktif dari data. Tampilan interaktif ini disebut sebagai Pivot Table Report. 

Dengan perangkat ini, kita dapat dengan mudah dan cepat menggolongkan data dalam 

kelompok-kelompok tertentu. 

Gambar berikut menunjukkan contoh tampilan sebuah pivot table. 

 

 

Gambar 12.1 Contoh sebuah Pivot Table 

 

Pivot table tersebut dihasilkan dari sebuah sumber data yang berisikan puluhan ribu data. 

Sumber data diolah dengan menggunakan pivot table sehingga menghasilkan ringkasan data 

yang diinginkan. Gambar berikut menunjukkan sebagian dari data yang dipakai untuk 

menghasilkan pivot table: 

 

 

Gambar 12.2 Sumber data untuk Pivot Table 

 

Kekuatan utama pivot table terletak pada kemudahan kita menghasilkan dan mengubah 

ringkasan data. Sebagai contoh, pada pivot table di gambar 14.1, kita bisa dengan mudah  

mengubah data jumlah penjualan menjadi data rata-rata penjualan. 

 

Struktur dasar sebuah pivot table disusun dari empat bagian berikut: 

 



1. Values 

2. Row 

3. Column 

4. Filter 

 

12.1 Persiapan untuk Membuat Pivot Table 

Untuk membuat sebuah pivot table, kita membutuhkan sebuah sumber data. Sumber data 

yang tepat untuk menghasilkan sebuah pivot table harus dibuat dengan tata letak tabular. 

Atribut-atribut yang menunjukkan tata letak tabular yang efektif adalah: 

• Baris pertama berisikan label judul 

• Tiap kolom merepresentasikan kategori data yang unik 

• Tiap baris merepresentasikan item untuk tiap kolom 

• Tidak ada baris ataupun kolom yang kosong 

Gambar berikut menunjukkan sumber data yang sudah diatur dengan baik untuk keperluan 

pembuatan pivot table. 

 

 

Gambar 12.3 Contoh Sumber Data yang baik untuk Pivot Table 

 

Gambar berikut menunjukkan sumber data yang tidak tepat untuk membuat pivot table. 



 

Gambar 12.4 Contoh Sumber Data yang tidak tepat untuk Pivot Table 

 

12.2 Membuat Pivot Table 

Untuk mulai membuat sebuah pivot table, klik pada salah satu sel di dalam sumber data. Ini 

untuk memastikan bahwa pivot table bisa menentukan secara otomatis data yang dipakai 

sebagai sumber. Selanjutnya pilih menu Insert > PivotTable 

 

 

Gambar 12.5 Menu Pivot Table 

 

Setelah memilih menu PivotTable tersebut, akan muncul kotak dialog Create PivotTable. 



 

 

Gambar 12.6 Dialog Create PivotTable 

 

Kotak dialog Create Pivot Table menanyakan dua buah pertanyaan, yaitu: 

1. Sumber data dari pivot table; bagian ini akan diisi secara otomatis jika kita sudah 

menempatkan kursor di dalam salah satu sel pada sumber data. Jika diperlukan, kita 

bisa mengganti isi dari bagian ini sesuai kebutuhan. 

2. Letak dari pivot table; pivot table bisa diletakkan pada worksheet baru atau di 

worksheet yang sudah ada. Isilah bagian ini sesuai kebutuhan. 

Setelah kedua pertanyaan tersebut dijawab, tekan tombol OK. Proses kustomisasi pivot table 

akan dimulai seperti tampil pada gambar berikut. Pada proses kustomisasi ini, kita perlu 

menentukan field- field yang akan dipakai ke dalam bagian-bagian dari pivot table. Pilih field 

yang diperlukan pada kotak dialog Pivot Table Field List, tarik field tersebut ke bagian yang 

diinginkan sesuai kebutuhan. 

Sebagai contoh, jika data yang dipakai untuk menunjukkan penjualan produk di tempat dan 

region tertentu. 

1. ∑ Values diisi dengan data penjualan (Sum of Sales) 

2. Column Labels diisi dengan nama produk (Product Description) 

3. Row Labels diisi dengan lokasi penjualan (Market) 

4. Report Filter diisi dengan daerah penjualan (Region) 



 

 

Gambar 12.7 Kustomisasi Pivot Table 

 

Contoh pengisian kotak dialog Pivot Table Field List bisa dilihat pada gambar berikut. 

 

 

Gambar 12.8 Kotak Dialog PivotTable Field List 

 



 

13 MEMBUAT DAN MERANCANG LAPORAN WORKSHEET DENGAN 

PIVOTTABLE SLICERS 

13.1 Membuat Dashboard di Ms.Excel Dengan Slicer  

Contoh dashboard di sini adalah sebuah bentuk pelaporan yang ditampilkan lebih sederhana, 

dengan menggunakan menu Slicer yang ada di Microsoft Excel 2010 ke atas. 

Langkahnya sebagai berikut: 

1. Memilih data yang akan dilaporkan. 

    Contoh: 

 

 

Gambar 13.1 Data Penjualan Juli 2013 

     

Contoh di sini akan dilaporkan dalam bentuk grafik, berdasarkan: 

• Nama Sales 

• Produk (Perdana) 

• Periode (Weekly) 

Contoh Pelaporan: 

 

 

Gambar 13.2 Contoh Dashboard Penjualan Dengan Slicers 

 



 

 

Langkahnya sebagai berikut: 

• Buatlah pivot table dari master data untuk Nama Sales 

 

 

Gambar 13.3. Langkah Membuat Tabel Pivot 

 

Pilih New Worksheet untuk menempatkan pivot table di sheet baru, atau Exiting 

Worksheet untuk menempatkan pivot table di sheet yang sama. Lalu, klik OK. 

 

 Tempatkan Nama Sales pada kolom Row Label, dan Qty pada kolom Value. 

 

 

Gambar 13.4 Hasil Insert Pivot Table 

 

• Buatlah grafik dari pivot table Nama Sales 



 

 

Gambar 13.5 Membuat Grafik/Chart Pivot 

 

 

 

Gambar 13.6 Tampilan Hasil Grafik Pivot 

 

Lalu pilih jenis grafik, misalkan jenis 2D. 

 

• Lanjutkan dengan membuat pivot dari master data untuk Produk dan grafik dari pivot 

Produk. Langkahnya sama dengan membuat pivot table Nama Sales dan grafik Nama 

Sales 

 

Gambar 13.7 Membuat Pivot Kedua Jumlah Produk 

http://2.bp.blogspot.com/-eWw38qK-KAo/UqVgVQYitzI/AAAAAAAAACk/X7MTsxAIQvw/s1600/gb3.png
http://2.bp.blogspot.com/-eWw38qK-KAo/UqVgVQYitzI/AAAAAAAAACk/X7MTsxAIQvw/s1600/gb3.png


 

 

Gambar 13.8 Grafik Hasil Pivot Jumlah Produk Terjual 

 

• Lanjutkan dengan membuat pivot dari master data untuk Periode dan grafik dari Pivot 

Periode. 

 

Gambar 13.9 Pembuatan Pivot Penjualan Per Periode 

 

 

Gambar 13.10 Grafik Pivot Penjualan Per Periode 

 

Dari hasil tersebut kita telah mempunyai 3 Pivot Table dan 3 grafik. 

 

 



 

 

Untuk menampilkan grafik dinamis dari beberapa kriteria, kita menggunakan menu Slicer. 

Langkah-langkahnya sebagai berikut:  

1. Tempatkan pointer mouse atau pilih salah satu cell di pivot table 

    Pilih Insert Slicer, lalu check list menu Slicer yang akan kita buat, misalnya Sales, 

Produk, dan Periode. 

 

 

Gambar 13.11 Insert Slicers 

 

2. Setelah klik OK, maka Slicer akan muncul 

 

 
 

3. Langkah selanjutnya adalah membuat koneksi Slicer 

Caranya dengan memilih salah satu Slicer, kemudian klik kanan, dan pilih Pivot Table 

Connection, lalu check list semua pivot table. (contoh Slicer Perdana). 

 

Gambar 13.12. Contoh Slicers 

  



 

Lakukan hal yang sama untuk Slicer yang lainnya. Pastikan semua pivot table terkoneksi 

dengan Slicer. 

 

4. Kemudian tinggal menata Slicer dan Grafik sesuai keinginan. 

 

 

Gambar 13.13 Dashboard Hasil Pivot Dan Slicers 

 

5. Jika ada perubahan master data, lakukan Refresh Pivot dan Slicer 

 

 



 

14 LAPORAN DAN GRAFIK   

14.1 Pencetakan 

Ukuran dari worksheet biasanya berbeda dengan ukuran kertas yang tersedia. Sehingga, 

seringkali kita harus melakukan pengaturan-pengaturan sebelum melakukan pencetakan.  Excel 

menyediakan beberapa fasilitas untuk membantu kita melakukan pengaturan-pengaturan 

tersebut.  Fasilitas yang cukup memudahkan antara lain menampilkan worksheet dalam mode 

tata letak halaman dan pengaturan Page Break. 

Untuk melihat worksheet dalam mode tata letak halaman pilih menu atau ribbon View, 

kemudian klik pada Page Layout di bagian Workbook Views. Tampilan akan berubah sebagai 

berikut: 

 

 

Gambar 14.1 Page Layout 

 

Tampilan ini akan membantu kita untuk melihat bagaimana worksheet tersebut dalam bentuk 

tercetak. Jika ada yang kurang sesuai, kita bisa pindah ke tampilan Page Break Preview. Untuk 

menampilkan Page Break Preview, pilih menu atau ribbon View, kemudian klik pada Page 

Break Preview di bagian Worksheet Views. Tampilan akan berubah sebagai berikut. 



 

 
 

Di tampilan ini, kita bisa menentukan di mana tempat memutus lokasi halaman. Untuk 

melakukan hal tersebut, klik pada garis pemutus halaman dan pindahkan ke tempat yang 

diinginkan. 

 

Pengaturan lain yang berkaitan dengan pencetakan bisa dilihat dengan menggunakan menu 

atau ribbon Page Layout di bagian Page Setup. 

 

Untuk menentukan bagian dari worksheet yang akan dicetak, lakukan prosedur berikut: 

1. Pilih daerah sel yang akan dicetak 

2. Pilih menu atau ribbon Page Layout 

3. Klik pada Print Area pada bagian Page Setup 

 

 

Gambar 14.2 Print Area 

 

4.  Klik Set Print Area 

 

Untuk melakukan pencetakan, pilih menu File > Print. Tampilan berikut akan muncul. 



 

 

Gambar 14.3 Dialog Menu Print 

 

Di tampilan ini, lakukan pengaturan-pengaturan yang dibutuhkan, kemudian klik Print. 

 

14.2 Grafik/Chart 

Untuk membuat grafik/chart,  kita memerlukan data yang hendak ditampilkan. Salah satu 

contoh data bisa dilihat pada gambar berikut: 

 

Gambar 14.4 Contoh Data untuk Grafik 

 

Jika data sudah tersedia, proses membuat grafik/chart bisa dilakukan dengan mudah. Caranya 

seperti ini: 

1. Klik salah satu sel di dalam lokasi data 

2. Pilih menu atau ribbon Insert 

3. Pada bagian Charts, pilih jenis grafik/chart yang diinginkan 

 



 

Gambar 14.5 - Insert > Charts 

 

4. Grafik/chart akan tampil di worksheet 

 

Gambar 14.6 Gambar 4 Contoh Grafik/Chart 

 

Untuk melakukan perubahan terhadap grafik/chart, klik pada grafik/chart yang bersangkutan. 

Di Menu Bar akan muncul menu atau ribbon tambahan dengan judul Chart Tools. Di 

bawah Chart Tools, ada tiga macam menu, yaitu: 

 

- Design 

- Layout 

- Format 

 

 

Gambar 14.7 Chart Tools 

 

Lakukan perubahan-perubahan yang diinginkan menggunakan Chart Tools sesuai kebutuhan. 

Di bagian Design, Anda mungkin akan sering menggunakan pemilihan Chart Layouts dan 

pemindahan grafik/chart ke worksheet lain menggunakan Move Chart. 

 

14.3 Advanced Chart 

14.4 Spin Button untuk Mengganti Jenis Chart 

Jika ada kebutuhan untuk menampilkan data yang sama dengan dua jenis chart yang berbeda, 

kita bisa memanfaatkan Spin Button untuk mengganti jenis chart yang sedang tampil. 

Tampilan chart bisa dilihat pada gambar berikut: 

 



 

 

Gambar 14.8 Chart dengan Spin Button 

 

Untuk meletakkan Spin Button, Anda harus masuk ke tab Developer, kemudian pilih menu 

Insert Spin Button di bagian Form Control. 

 

 

Gambar 14.9 Tab Developer pada Ribbon 

 

Jika tab Developer belum aktif, kita perlu mengaktifkan melalui menu File > Options > 

Customize The Ribbon. 

 



 

 

Gambar 14.10 Customize Ribbon 

 

Setelah Spin Button tersedia, selanjutnya adalah melakukan kustomisasi terhadap Spin Button. 

Untuk keperluan kustomisasi, klik kanan pada Spin Button dan pilih menu Format Control. 

 

Data untuk kustomisasi adalah sebagai berikut: 

 

- Minimum Value: 1 

- Maximum Value: 2 

- Incremental Change: 1 

- Cell Link: $E$3 

 

Lakukan perubahan sesuai kebutuhan. Jika Anda ingin menampilkan lebih dari dua chart, 

gantilah nilai maksimum sesuai dengan jumlah chart. 



 

 

Gambar 14.11 Kotak Dialog Format Control untuk Spin Button 

 

Setelah Spin Button tersedia, lakukan prosedur berikut: 

 

1. Salin nilai data dari kolom C ke kolom lain sejumlah jenis chart yang diinginkan. Sebagai 

contoh, data akan disalin dua kali, yaitu ke kolom E dan F. 

2. Buatlah chart dengan data di kolom B sebagai label, dan kolom E dan F sebagai data series. 

3. Pilih chart yang diinginkan untuk masing-masing data series. 

4. Lakukan pengaturan-pengaturan yang diinginkan untuk chart tersebut. 

5. Masukkan formula berikut: 

=IF($E$3=1;$C6;#N/A) pada sel E6, kemudian salin ke sel-sel di bawahnya. 

=IF($E$3=2;$C6;#N/A) pada sel F6, kemudian salin ke sel-sel di bawahnya. 

 

Setelah prosedur tersebut dilakukan, kita bisa menekan tombol panah atas dan bawah dari Spin 

Button untuk mengganti chart yang tampil. 

 

14.5 Menandai Nilai Maksimum pada Chart 

Adakalanya, kita menghasilkan chart dengan jumlah data yang cukup banyak. Dari sekian 

banyak data tersebut, akan sangat menolong jika ada data tertentu yang perlu ditonjolkan, 

misalnya nilai maksimum dari semua data yang ada. Gambar berikut menunjukkan contoh 

seperti dimaksud: 

 



 

 

Gambar 14.12 Penandaan Nilai Max pada Chart 

 

Untuk menghasilkan chart seperti pada gambar, lakukan prosedur berikut: 

1. Salin data asal dari kolom C ke kolom D 

2. Buatlah chart dengan data di kolom B sebagai label, dan kolom C dan D sebagai data series 

3. Pilih jenis chart dengan Marker untuk data series D (misal: Line with Markers) 

4. Hilangkan garis dengan memilih No Line pada Line Color 

5. Masukkan formula berikut pada data di sel D4 

=IF($C4=MAX($C$4:$C$15);$C4;#N/A) 

6. Salin ke sel lain di kolom D untuk semua data 

7. Untuk menampilkan nilai data maksimum, klik pada marker data maksimum dan pilih Add 

Data Label. 

 

Penanda nilai maksimum ini bisa juga dipakai untuk menandai nilai minimum. Untuk keperluan 

tersebut, ganti fungsi MAX menjadi fungsi MIN. 

 

14.6 Penanda Bergerak pada Chart 

Pada bagian ini, dengan menekan tombol Scroll Bar pada chart, garis penanda maksimum dan 

minimum akan bergeser, dan nilai yang sedang aktif akan ditampilkan. 

 



 

 

Gambar 14.13 Penanda Bergerak pada Chart 

 

Untuk keperluan pembuatan chart tersebut, diperlukan data sebagai berikut: 

 

- Kolom untuk menampung data posisi Scroll Bar (No) → Kolom A 

- Kolom untuk menampung data Label (Date) → Kolom B 

- Kolom untuk penanda maksimum (Max) → Kolom C 

- Kolom untuk data series (Value) →  Kolom D 

- Kolom untuk penanda minimum (Min) → Kolom E 

- Kolom untuk penanda nilai aktif (Marker) → Kolom F 

- Sel untuk data posisi aktif Scroll Bar (Sel F1) 

 

Setelah mempersiapkan data dan membuat chart, langkah selanjutnya adalah menambahkan 

Scroll Bar. Pilih tab Developer, kemudian pilih menu Insert Scroll Bar di bagian Form 

Control. Letakkan Scroll Bar di tempat yang diinginkan, kemudian lakukan kustomisasi 

dengan menampilkan kotak dialog Format Control (klik kanan pada Scroll Bar, dan pilih 

Format Control). 

 

Data untuk kustomisasi adalah sebagai berikut: 

 

- Minimum Value: 1 

- Maximum Value: 52 (ada 52 data pada contoh yang diberikan) 

- Incremental Change: 1 

- Cell Link : $F$1 



 

 

Gambar 14.14 Kotak Dialog Format Control untuk Scroll Bar 

 

Prosedur selanjutnya adalah sebagai berikut: 

1. Untuk data series kolom D, pilih jenis chart Line 

2. Untuk data series kolom C, E, dan F pilih jenis chart Line with Markers 

3. Hilangkan garis pada data series kolom C, E, dan F dengan memilih No Line pada Line 

Color 

4. Masukkan formula-formula berikut: 

=IF($A3=$F$1;MAX($D$3:$D$54);#N/A)  di sel C3, kemudian salin ke sel-sel di 

bawahnya 

=IF($A3=$F$1;MIN($D$3:$D$54);#N/A)  di sel E3, kemudian salin ke sel-sel di 

bawahnya 

=IF(ISNA($E3);$E3;$D3)  di sel F3, kemudian salin ke sel-sel di bawahnya 

5. Klik pada salah satu marker, kemudian sisipkan High-Low Lines melalui tab Layout di 

Chart Tools, kemudian pilih Lines >  High-Low Lines 

 

 

Gambar 14.15 High-Low Lines 



 

14.7 Chart Dinamis 

Chart dinamis akan menampilkan infomasi baru jika ada tambahan data, baik itu secara 

keseluruhan ataupun hanya beberapa nilai terakhir. Gambar di bawah menunjukkan contoh 

chart tersebut. 

 

Gambar 14.16 Chart Dinamis 

 

Untuk menghasilkan chart tersebut, yang perlu dilakukan adalah mendefinisikan Name untuk 

keperluan pemilihan sumber data. 

 

Untuk mendefinisikan Name, pilih menu Formulas > Define Name, kotak dialog New Name 

akan muncul. 

 

 

Gambar 14.17 Kotak Dialog New Name 

 

Definisikan Name berikut untuk menampilkan semua data sampai dengan data terbaru. 

 

Name Refers to 

Tanggal =OFFSET(DynamicChart!$A$1;1;0;COUNTA(DynamicChart!$A:$A)-1) 

Value =OFFSET(DynamicChart!$B$1;1;0;COUNTA(DynamicChart!$B:$B)-1) 

 



 

Untuk menampilkan beberapa data terakhir (misal: 30 data), definisikan Name berikut: 

 

Name Refers to 

Tanggal =OFFSET(DynamicChart!$A$1;COUNTA(DynamicChart!$A:$A)-30;0;30) 

Value =OFFSET(DynamicChart!$B$1;COUNTA(DynamicChart!$B:$B)-30;0;30) 

 

Sesudah Name didefinisikan, buatlah chart dan buka kotak dialog Select Data Source. 

 

Gambar 14.18 Menu Select Data 

 

Selanjutnya, pada kotak dialog Select Data Source, lakukan penyesuaian dengan mengatur 

informasi untuk Legend Entries (Series) dan Horizontal (Category) Axis Labels. 

 

 

Gambar 14.19 Kotak Dialog Select Data Source 

 

Untuk Legend Entries (Series), masukkan informasi seperti pada gambar berikut: 

 

 



 

Gambar 14.20 Edit Series 

 

Untuk Axis Labels, masukkan informasi seperti pada gambar berikut: 

 

 

Gambar 14.21 Axis Label 

 

14.8 Membuat Grafik dengan Excel untuk Data Beberapa Kolom  

Misalnya, Anda adalah mahasiswa sekolah kesehatan yang ditugaskan untuk membuat sebuah 

daftar dari hasil pemeriksaan tekanan darah untuk 3 macam obat yang berbeda, dengan data 

pemeriksaan tiap jam selama 6 jam. Setelah Anda memasukkan data ke dalam Excel, 

tampilannya akan terlihat seperti ini: 

 

Sekarang waktunya mengubah data mentah ke bentuk grafis tiga baris. Skala horizontal sumbu 

(X) adalah waktu (jam), dan tingkat tekanan darah sebagai sumbu vertikal. Caranya adalah 

sebagai berikut: 

Pertama, klik tab Insert (yang dilingkari) untuk menampilkan menu pilihan Toolbar Insert. 

 



 

 

Klik pada Line Chart (yang dilingkari). Pilih jenis (style) line chart yang Anda inginkan dari 

menu popup yang muncul. Grafik (chart) akan muncul sesuai dengan data Anda. 

 

Hampir selesai! Selanjutnya, Anda dapat memendekan sumbu vertikal agar dapat melihat detil 

pada grafik dengan lebih jelas. 



 

 

Klik kanan pada sumbu yang ingin Anda ubah, dan pilih Format Axis. Ubah nilai dalam kotak 

popup untuk mengubah grafik dengan skala yang Anda inginkan, tambahkan atau ubah baris 

properti, atau detail lainnya. Semua axis, legend (legenda), baris, dan lain-lain dalam grafik 

dapat diedit dengan cara ini. 

 

Dan ini adalah hasilnya! Anda dapat juga memindahkan grafik ini ke sheet lain, dan bahkan 

dapat meng-copy-nya ke word document. 

  

Lihat lainnya di http://excel.aurino.com/2009/01/bagaimana-membuat-grafik-dengan-excel-

untuk-data-beberapa-kolom/#sthash.BZbgGmsR.dpuf 

 



 

15 WHAT-IF ANALYSIS 

Salah satu bagian terpenting dari penggunaan software spreadsheet (Excel) adalah kemampuan 

untuk melakukan analisa what-if dengan cepat dan mudah. Sebagai contoh, kita bisa 

menggunakan Excel untuk mengambil keputusan dalam pengambilan fasilitas kredit 

rumah/mobil, berapa sebaiknya uang muka yang harus kita sediakan, dan berapa lama kita 

hendak melunasi fasilitas kredit. Kita bisa melakukan simulasi dengan berbagai macam asumsi 

tentang suku bunga, jumlah uang muka, dan lama pembayaran. 

 

15.1 Goal Seek 

Dengan menggunakan Goal Seek kita bisa menghitung nilai yang belum diketahui yang 

diperlukan untuk memberikan hasil tertentu. Contoh, kita ingin mengetahui nilai maksimum 

dari sebuah pinjaman selama 30 tahun yang dibatasi bahwa angsuran per bulan maksimum 

adalah Rp. 2.000.000,-. Dengan menggunakan Goal Seek, hal ini bisa diselesaikan. 

 

Gambar berikut adalah worksheet yang diperlukan: 

 

 

Gambar 15.1 Goal Seek 

 

Berikut prosedur yang diperlukan: 

1. Pilih sel A1:B4 

2. Tekan Ctrl+Shift+F3 atau pilih menu Formulas > Create From Selection untuk 

mendefinisikan nama bagi sel B1-B4 

3. Window berikut akan muncul 



 

 

Gambar 15.2 Create Range Name  From Selection 

 

4. Pilih Left column 

5. Letakkan kursor di sel B4 

6. Ketikkan formula 

=PMT(Bunga/12;Jangka_Waktu*12;Nilai_Pinjaman) 

7. Pilih kembali sel B4, kemudian pilih menu Data > What-If Analysis >  Goal Seek 

 

Gambar 15.3 Goal Seek 

 

8. Isikan nilai yang diinginkan seperti pada gambar, lalu klik tombol OK 

 

15.2 Skenario dalam Excel 

Skenario berada di bawah menu What-If Analysis di Excel. Skenario dapat disimpan, 

sehingga Anda dapat memanggil kembali pada saat diperlukan. 

Contoh penerapan skenario: Anda memiliki anggaran pengeluaran keluarga. Kemudian, Anda 

mencoba mengubah pengeluaran pos-pos tertentu, misalnya makanan, pakaian, atau bahan 

bakar, dan melihat bagaimana perubahan ini mempengaruhi anggaran secara keseluruhan.  

Pertama, buat anggaran serupa dengan tabel di bawah ini:  



 

 

Gambar 15.4 Skenario Anggaran Rumah Tangga 

Angka dalam sel B12 di atas dapat menggunakan fungsi SUM, yang merupakan total 

pengeluaran Anda. Sedangkan angka dalam sel C3 adalah pendapatan Anda setiap bulan. 

Angka dalam sel D13 adalah berapa banyak sisa pendapatan Anda setelah dikurangi semua 

pengeluaran. 

Dengan hanya Rp. 460.000,- yang tersisa setiap bulan, maka harus dibuat perubahan. Kita akan 

membuat skenario untuk melihat bagaimana pengaruh pemotongan pos-pos anggaran tersebut. 

Caranya adalah: 

• Pilih tab Data 

• Pada tab Data, klik Data Tools Group  

• Klik pada What-If -Analysis, dan pilih Scenario Manager 



 

 

Gambar 15.5 Kelompok Icon Data Tools 

Setelah meng-klik Scenario Manager maka akan tampil dialog box sebagai berikut: 

 

Gambar 15.6 Dialog Scenario Manager 

Kita ingin membuat skenario baru. Jadi klik tombol Add. Anda kemudian akan mendapatkan 

kotak dialog lain muncul: 



 

 

Gambar 15.7 Dialog Menambahkan Scenario 

J12 yang ada di field Changing Cells adalah sel terakhir yang Anda pilih sebelum mengklik 

Scenario Manager. Kita akan mengubah sel ini. Langkah pertama, ketik Nama untuk skenario 

Anda di kotak Scenario name. Misalnya Anggaran Asli. 

Anda harus memasukkan sel-sel dalam spreadsheet yang akan diubah. Dalam skenario pertama 

(Anggaran Asli), tentu saja tidak ada yang akan diubah. Namun demikian, Anda harus 

memasukkan sel-sel mana yang akan diubah. Misalnya, Anda coba untuk mengurangi 

pengeluaran Makanan, Baju, dan Telepon. Sel yang ditempati oleh anggaran ketiga pos 

tersebut adalah sel B7 sampai sel B9. Jadi, isilah kotak Changing Cells dengan B7:B9, jangan 

lupa titik dua (:) di antara dua sel tersebut, atau titik koma (;) jika Anda menggunakan regional 

setting Indonesia. 



 

 

Klik OK dan Excel akan meminta Anda untuk memasukkan beberapa nilai: 

 

Gambar 15.8 Input Nilai Sel Yang Diubah Dalam Scenario 

Karena Anda ingin skenario ini sebagai Anggaran Asli, maka klik OK saja. Akan muncul 

dialog box Scenario Manager sebagai berikut: 



 

 

Gambar 15.9. Pemberian Nama Scenario 

Anda dapat menambahkan satu skenario lagi. Pada langkah ini. kita coba memasukkan nilai 

baru: Tabungan. 

Klik tombol Add lagi. Ketik nama baru, misalnya Anggaran Dua. Changing Cells berisi B7: 

B9. Klik OK. 

Anda akan dibawa ke kotak Scenario Value dialog. Sekarang, Anda ingin mengubah nilai. 

Masukan 1800000 untuk B7, 1000000 untuk B8, dan 250000 pada B9. seperti pada gambar di 

bawah ini: 

 

Nilai ini adalah nilai baru untuk Anggaran. Klik OK. Anda dapat melihat kembali Scenario 

Manager, dan terlihat ada dua skenario dalam list-nya: 



 

 

Terlihat bahwa kita memiliki Anggaran Asli dan Anggaran Dua. Klik tombol Show di bagian 

bawah Scenario Manager dengan Anggaran Dua terpilih. Nilai-nilai dalam spreadsheet Anda 

akan berubah, dan anggaran baru akan dihitung. Gambar di bawah menunjukkan apa yang 

tampak seperti di spreadsheet: 

 

Gambar 15.10 Model Scenario Anggaran Rumah Tangga 

Klik pada Anggaran Asli, kemudian klik tombol Show. Nilai-nilai awal akan ditampilkan. 

Klik tombol Close pada dialog box untuk mengakhiri. 



 

Skenario memberikan Anda cara yang berbeda untuk melihat satu set angka, dan dengan 

mudah Anda dapat beralih dari alternatif angka yang diinginkan. 

 

Cara Membuat Laporan Skenario 

Selain membuat skenario, Anda dapat membuat laporan skenario. Untuk membuat laporan 

skenario, maka langkahnya adalah sebagai berikut:  

•  Klik tab Data pada Excel Bar 

• Cari Data Tools Group 

• Pada Tools Data Group, klik What-If-Analysis 

• Dari What-If-Analysis, klik Scenario Manager 

• Dari kotak dialog Scenario Manager, klik tombol Summary untuk menampilkan kotak dialog 

berikut: 

 

Gambar 15.11 Dialog Scenario Summary 

Dialog box di atas memberikan Anda pilihan sel-sel mana yang akan tampil pada laporan. 

Untuk mengubah sel pada Result Cells, klik pada spreadsheet Anda. Klik sel-sel dengan 

menekan tombol [CTRL] pada keyboard, dan mengklik sel dengan tombol kiri mouse Anda. 

Pilih sel C3, B12, dan C13. Jika Anda ingin menyingkirkan sel yang dipilih, klik lagi dengan 

tetap menekan tombol [CTRL]. Selanjutnya, jika sudah memilih, klik OK. Excel akan 

membuat ringkasan skenario Anda: 



 

 

Gambar 15.12 Hasil Scenario 

 

 

15.3 Data Tables dalam Excel 

Dalam Excel, Data Table adalah cara untuk melihat hasil berbeda-beda dengan mengubah 

sebuah sel masukan dalam rumus. Sebagai contoh, Anda akan mengubah tingkat bunga dan 

melihat berapa bunga yang akan dikenakan dari pinjaman sebesar Rp. 100.000.000,- setiap 

bulannya. Tingkat bunga merupakan sel input. Dengan memerintahkan kepada Excel untuk 

mengubah input ini, maka Anda dapat dengan cepat melihat pembayaran bulanan yang 

berbeda-beda. Sebagai contoh, Anda ingin tahu berapa banyak yang harus kita bayar setiap 

bulannya jika tingkat bunga adalah 24% per tahun. Akan tetapi, bank lain menawarkan tingkat 

bunga lain, misalnya 22% per tahun, 20% per tahun, dan 18% per tahun. 

 

Untuk membuat perhitungan tersebut kita memakai formula PMT dengan syntax: 

PMT(rate, nper, pv, fv, type). 

Namun, dalam perhitungan ini, kita hanya perlu tiga parameter jadi: 

PMT(rate, nper, pv). 

Dimana: 

Rate berarti tingkat bunga. Parameter atau argumen kedua, nper, adalah periode pembayaran 

atau berapa bulan Anda harus membayar kembali pinjaman. Argumen ketiga, pv, adalah nilai 

pinjaman saat ini atau seberapa banyak Anda ingin meminjam. 

Baiklah kita membuat spreadsheet baru dengan tingkat bunga 24%, periode 5 tahun atau 60 

bulan, dengan jumlah pinjaman Rp. 100.000.000,-, sebagai berikut: 



 

 

Gambar 15.13 Worksheet Pembayaran Hutang 

Kemudian di D2 kita masukkan Pembayaran Cicilan/bulan, dan di D3 masukkan formula 

PMT() untuk menghitung besarnya pembayaran cicilan per bulan, yaitu: 

 

=PMT(B4/12,B5,-B6) 

 

Nilai Rate yang dimasukkan ke dalam rumus harus dibagi 12 terlebih dahulu karena 

merupakan pembayaran bulanan, sedangkan tingkat bunga adalah tahunan. Sedangkan 

periode (nper) langsung dimasukkan. Untuk nilai pinjaman (pv), masukkan nilai minus (-), 

karena dianggap sebagai pinjaman, sehingga nilai pembayaran per bulan (PMT) nantinya akan 

mendapatkan nilai positif. 

 

Gambar 15.14 Memasukkan Rumus Cicilan (PMT) 

Letakkan fungsi PMT di sel D3 karena sel D3 berada satu baris di atas dan satu kolom di 

samping kanan angka tingkat bunga 22%. Nantinya, pembayaran bulanan dengan bunga 

masing-masing berada di sel D4 sampai dengan D6. Excel memang menetapkan Data Table 

layout sedemikian rupa. 



 

Agar Excel dapat menghitung total pembayaran bulanan baru berdasarkan bunga yang Anda 

masukkan ke dalam sel C4 s/d C6 sesuai dengan fungsi yang telah kita tuliskan pada sel D4, 

sorotlah sel C3 sampai dengan D6 seperti gambar di bawah ini: 

 

Gambar 15.15 Pembuatan Data tabel 1 

Setelah sel C3 s/d D6 dipilih, maka Anda dapat membuat Data Table Excel, sehingga 

hasilnya adalah pembayaran bulanan baru. Caranya: 

• Dari menu Excel, klik Data 

• Cari Data Tools group 

• Klik panah kecil sebelah kanan “What-If Analysis” 

  

 

Gambar 15.16 Menu Data Table Icon dalam What -iF -Anaylisis 

• Lalu klik Data Table… sehingga muncul kotak dialog 



 

 

Gambar 15.17. Input Sel Baris dan Kolom dalam Data Table 

Pada kotak dialog, yang perlu diisi adalah Row input cell atau Column input cell. Jika Anda 

menginginkan Excel untuk mengisi ke bawah, arah kolom, Anda perlu kotak teks kedua pada 

dialog box, yaitu Column input cell. Jika kita ingin mengisi baris, gunakan Row input cell. 

Yang kita anggap sebagai sel masukan adalah sel yang berisi tingkat bunga. Sel ini adalah sel 

yang harus diubah oleh Excel. 

Jadi, klik di dalam Column input cell dan masukkan B4: 

 

Klik OK, maka Excel akan mengisi sel-sel yang berada di bawah D3, yaitu D4, D5, D6 

menjadi sebagai berikut: 

 

Gambar 15.18. Hasil Data Table 

Jadi, kalau kita mendapatkan tingkat bunga 18%, maka pembayaran bulanan adalah Rp. 

2.639.442,- 



 

Jika Anda pilih sel D4 s/d D6 maka dalam kotak formula akan tampil {=TABLE(,B4)} yang 

berarti bahwa sel tersebut diperoleh dari input sel B4. 

 Bagaimana kalau kita ingin bentuk hasil mendatar atau berada dalam satu baris? Misalnya, 

dengan bentuk sebagai berikut: 

 

Gambar 15.19 Data tabel Horizontal 

Maka pilihan kita adalah sel B4 s/d E5: 

 

Gambar 15.20 Blok Range Untuk Data Table 

Kemudian kita lakukan langkah sebagai berikut: 

• Dari menu Excel, klik Data 

• Cari Data Tools group 

• Klik panah kecil sebelah kanan “What-If Analysis” 

  



 

 

• Laku Klik Data Table… sehingga muncul kotak dialog 

 

Yang kita anggap sebagai sel masukan adalah sel yang berisi tingkat bunga. Sel ini adalah sel 

yang harus diubah oleh Excel. 

Jadi, klik di dalam Row input cell dan masukkan B4: 

 

Klik OK, maka Excel akan mengisi sel-sel yang berada di kanan B5, yaitu C5, D5, E5 

menjadi sebagai berikut: 

 

Gambar 15.21 Contoh Data Table Horisontal 



 

Sama halnya dengan perhitungan melalui kolom. Kalau kita mendapatkan tingkat bunga 

18%, maka pembayaran bulanan adalah Rp. 2.639.442,74 

Jika Anda pilih sel C5 s/d E5 maka dalam kotak formula akan tampil {=TABLE(B4,)} yang 

berarti bahwa sel tersebut diperoleh dari input sel B4. 

 



 

16 TIPS TAMBAHAN 

16.1 Memasukkan Data 

Untuk memasukkan data ke dalam Excel, lakukan prosedur sebagai berikut: 

 

1. Pilih sel yang akan diisi dengan menggunakan mouse atau keyboard (tombol kursor) 

2. Setelah sel terpilih, ketikkan data yang ingin dimasukkan 

3. Setelah selesai, tekan tombol Tab atau Enter 

Jika tombol tab ditekan, kursor akan berpindah ke sel berikutnya. Jika tombol enter ditekan, 

kursor akan pindah satu baris ke bawah. 

4. Jika ingin tetap berada di sel yang bersangkutan, jangan tekan tombol tab atau enter, 

tetapi klik pada simbol √ di sebelah kiri Formula Bar 

 

Gambar 16.1 Formula Bar 

 

9. Jika ingin batal memasukkan data, tekan tombol Esc atau klik pada simbol X di sebelah 

kiri Formula Bar. 

Jika  terjadi  kesalahan  memasukkan  data,  pilih  sel  yang  akan  diubah.  Untuk  mengubah 

sebagian, tekan tombol F2. Untuk melakukan perubahan keseluruhan lakukan pengetikan 

ulang. 

 

Jenis data yang bisa dimasukkan ke dalam Excel adalah sebagai berikut: 

 

• Label/Teks; merupakan data non-numerik. Label biasanya dipakai untuk membuat judul 

worksheet, heading dari tabel maupun kolom. Bisa juga berupa data-data seperti nama, 

alamat, dan sebagainya. 

• Values/Angka; merupakan data numerik. Termasuk di dalam jenis data ini adalah simbol 

mata uang, prosentase, pecahan. 

• Tanggal; data numerik yang berisi tanggal. 

• Waktu; data numerik yang berisi waktu. 

• Formula; informasi matematis yang memberitahu Excel untuk melakukan perhitungan 

persamaan yang menggunakan nilai-nilai di dalam worksheet. Contoh: =A1+A2+A3 akan 

memberitahu Excel untuk menjumlahkan nilai-nilai di sel A1 dan A2 dan A3, kemudian 

menampilkan hasilnya. 

• Fungsi; merupakan bentuk perhitungan lebih kompleks yang disediakan oleh Excel. 

Contoh: =SUM(A1:A10)  akan  menjumlahkan  nilai-nilai  yang  berada  di  sel  A1  sampai  

A10  kemudian menampilkan hasilnya. 



 

 

16.2 Alamat Sel 

Alamat sel dalam format yang paling umum berupa alamat kolom dan alamat baris. Sebagai 

contoh, jika sebuah sel berada di kolom A dan baris 1, maka alamat sel yang bersangkutan 

adalah A1. 

 

Gambar 16.2 Referensi Sel A1 

 

Selain menyebutkan alamat kolom dan baris, Anda bisa juga menyertakan nama worksheet 

dan workbook pada alamat sel. Contoh penyebutan alamat dengan menyertakan nama 

worksheet adalah sebagai berikut: 

 

Sheet1!A1 

 

Sheet1 merupakan nama worksheet yang bersangkutan. 

 

Contoh penyebutan alamat dengan menyertakan nama worksheet dan workbook adalah sebagai 

berikut:  

 

[Book1.xlsx]Sheet1!A1 

 

Book1 merupakan nama workbook yang bersangkutan. 

 

Alamat untuk sekelompok sel (disebut juga range), dimulai dengan alamat sel pojok kiri 

atas, tanda [:] dan diakhiri dengan alamat sel pojok kanan bawah. Contoh bisa dilihat pada 

gambar berikut untuk kelompok sel dengan alamat B3:E9. 



 

 

Gambar 16.3 Referensi Range (Sel-sel)  B3:E9 

 

Selain menyebutkan alamat dengan cara di atas, alamat sel bisa diganti dengan nama yang 

didefinisikan oleh pengguna. Untuk memberi nama kepada sebuah sel atau sekelompok sel 

tertentu, langkah yang harus dilakukan adalah sebagai berikut: 

1. Pilih sel atau kelompok sel yang diinginkan 

2. Ketikkan nama yang diinginkan di Name Box 

 

 

Gambar 16.4 Name Box (Nama Range/Sel) sel terpilih 

 

16.3 Manajemen File 

Setiap kali Anda membuka Excel, maka sebuah workbook kosong akan terbuka, sehingga Anda 

bisa segera memasukkan data. Pada saat kita bekerja dengan workbook, semua perubahan akan 

disimpan sementara ke dalam memori komputer. Untuk menghindari risiko kehilangan data, 



 

sebaiknya kita harus menyimpan workbook secara rutin ke dalam sebuah file. Untuk 

menyimpan, lakukan langkah-langkah berikut: 

1. Pilih menu File > Save atau klik pada simbol disk di sebelah kiri atas 

 

Gambar 16.5 Menyimpan File 

 

2. Pada saat pertama kali menyimpan, akan muncul kotak dialog untuk memberi nama file. 

Pilihlah tempat menyimpan file dan beri nama sesuai kebutuhan, kemudian klik tombol 

Save 

 

Gambar 16.6 Memberi Nama File 

 

3. Untuk penyimpanan yang berikutnya, komputer akan langsung menyimpan pekerjaan ke 

dalam file 

 

Sebagai catatan, pada saat memberikan nama, usahakan untuk memberi nama yang 

menjelaskan file tersebut. Tambahkan juga informasi tentang versi file berupa urutan angka 

atau tanggal. Hal ini akan memudahkan untuk mencari file dan menentukan file mana yang 

paling akhir dikerjakan. 

 

Adakalanya kita perlu menyimpan sebuah file ke dalam file dengan nama lain. Untuk 

menyimpan file dengan nama lain, lakukan prosedur berikut: 



 

1. Pilih menu File >  Save As 

2. Pilih tempat menyimpan file dan ketikkan nama file yang diinginkan, kemudian klik tombol 

Save 

 

Untuk membuka file yang sudah tersimpan, lakukan prosedur berikut: 

1.   Pilih menu File > Open 

2.   Pilih lokasi file yang diinginkan, pilih nama file yang bersangkutan 

3.   Klik tombol Open 

 

Jika file yang diinginkan baru saja dibuka, bisa juga dilakukan prosedur berikut: 

1.   Pilih menu File > Recent 

2.   Pilih dan klik pada nama file yang berada dalam daftar 

 

Excel versi 2010 juga memberikan pilihan untuk membuka file yang lupa kita simpan. Untuk 

memanfaatkan pilihan ini, lakukan prosedur berikut: 

1.   Pilih menu File > Recent 

2.   Klik pada pilihan Recover Unsaved Workbooks di sebelah kanan bawah 

3.   Pilih file yang diinginkan, kemudian klik tombol Open 

 

16.4 Formatting 

Pengaturan format yang berlaku untuk sel atau sekelompok sel dilakukan melalui menu atau 

ribbon Home. 

 

 

Gambar 16.7 Tab/Menu Home 

 

Jika ingin mengatur format dengan cara klasik, pilih menu Home > Format > Format Cells 

…. Akan muncul tampilan sebagai berikut: 



 

 

Gambar 16.8 Dialog Format Cells 

 

Pengaturan format yang akan paling sering dilakukan adalah mengatur format untuk: 

• Number; pengaturan tentang bagaimana menampilkan informasi sesuai dengan jenis data 

yang dimasukkan. 

• Alignment; pengaturan tampilan berkaitan dengan batas-batas sel. 

• Font; pengaturan jenis huruf dan atribut yang berkaitan untuk menampilkan informasi. 

• Number; dalam Format Number, informasi bisa dikategorikan sebagai berikut: 

 

• General • Menampilkan data tanpa atribut apapun 

• Number • Menampilkan angka ditambah dengan nilai desimal di belakang 

koma 

• Currency • Menampilkan simbol mata uang diikuti dengan angka. Angka 

negatif ditampilkan dengan gaya tertentu. 

• Accounting • Sama dengan Currency, tapi tidak mengatur angka negatif 

• Date • Memberikan pilihan untuk menampilkan tanggal dengan format-

format tertentu 

• Time • Memberikan pilihan untuk menampilkan waktu dengan format-

format tertentu 

• Percentage • Menambilkan angka ditambah dengan simbol % 

• Fraction • Menampilkan angka dalam bentuk pecahan 

• Scientific • Menampilkan angka dengan notasi ilmiah 

• Text • Untuk memberitahu Excel agar angka yang dimasukkan 

diperlakukan sebagai teks 

• Special • Mengatur  format-format  khusus  seperti  kode  pos,  telpon  dan  

lain-lain  yang sebetulnya bukan merupakan angka numerik 

• Custom • Untuk membuat format yang didefinisikan oleh pengguna 

 

Contoh tampilan bisa dilihat di gambar berikut: 



 

 

Gambar 16.9 Dialog Format Number 

 

Untuk pengaturan alignment (perataan), apa saja yang bisa diatur dapat dilihat pada gambar 

berikut: 

 

 

Gambar 16.10 Dialog Format Alignment (Perataan) 

 

Beberapa fitur yang mungkin akan sering digunakan antara lain adalah: 

• Pengaturan Text Alignment untuk Horizontal maupun Vertical 

• Pengaturan Orientation 

• Pengaturan Wrap text 

 



 

Untuk pengaturan font, apa saja yang bisa diatur dapat dilihat pada gambar berikut: 

 

Gambar 16.11 Format > Font 

 

Dari tampilan, format yang bisa diatur antara lain adalah: 

• Jenis Font 

• Style dari Font 

• Ukuran Font 

• Warna Font 

• Garis bawah dan efek-efek lain 

 

Kalau diperhatikan, tampilan di atas sedikit berbeda dengan apa yang bisa dilihat pada 

ribbon Home bagian Font. Bagian yang tidak tersedia adalah Fill Color dan Border. Bagian 

tersebut bisa juga diakses melalui tab Fill dan Border pada gambar di atas. 

 

Disamping pengaturan format seperti disebutkan di atas, ada beberapa tips yang mungkin bisa 

membantu dalam mengatur penampilan format worksheet. 

 

16.5 Tips 1 

Semua pengaturan format sel bisa disalin ke sel-sel yang lain dengan menggunakan Format 

Painter. Untuk melakukan hal tersebut, lakukan prosedur berikut: 

1. Pilih sel yang akan disalin formatnya 

2. Pilih menu atau ribbon Home 

3. Klik pada Format Painter 



 

 

Gambar 16.12 Format Painter 

 

4. Klik pada sel tujuan 

 

16.6 Tips 2 

Jika data yang dimasukkan membentuk tabel, kita bisa mengatur tampilan dengan gaya 

yang sudah didefinisikan. Untuk melakukan hal tersebut, lakukan prosedur berikut: 

1. Pilih kelompok sel yang akan dibentuk menjadi tabel 

2. Pilih menu atau ribbon Home 

3. Klik pada Format as Table 

 

 

Gambar 16.13 Format as Table 

 

3. Pilih gaya tabel yang diinginkan 

 

16.7 Tips 3 

Untuk mengatur ukuran sel dengan mudah, lakukan prosedur berikut: 

1. Pilih sel yang akan diatur 

2. Pilih menu atau ribbon Home > Format 



 

 

Gambar 16.14 Cell Size 

 

4. Atur ukuran sel sesuai kebutuhan dengan menggunakan menu Cell Size 

 

16.8 Tips 4: Mengubah Huruf di Bagian Depan Menjadi Huruf Kapital 

 

 

Gambar 16.15 Huruf Besar di Bagian Depan Nama 

 

Formula yang digunakan di sel C3 adalah: 

 

=PROPER(A3) 

 

 



 

16.9 Tips 5: Menggabungkan Isi Dua Buah Sel String 

 

Gambar 16.16 Menggabungkan Isi Dua Sel String 

 

Formula yang digunakan di sel F3 adalah: 

 

=PROPER(B3&" "&A3) 

 

16.10 Tips 6: Proteksi Worksheet 

Untuk melindungi sebuah worksheet dari perubahan yang tidak disengaja, gunakan menu 

Review > Protect Sheet 

 

 

Gambar 16.17 Mem-protect  WorkSheet 

 

Kotak dialog Protect Sheet akan muncul. Berikan tanda pada pilihan yang diinginkan, serta 

password jika diperlukan. 

 



 

 

Gambar 16.18 Kotak Dialog Protect Sheet 

 

16.11 Tips 7: Kustomisasi Ikon pada Data di dalam Sel 

 

Gambar 17.19 Kustomisasi Ikon 

 

Untuk menampilkan ikon di dalam sel, pilih tab Home > Conditional Formating > Icon Sets. 

 

Untuk pengaturan yang lebih detail, pilih tab Home > Conditional Formating > Icon Sets > 

More Rules 



 

 

Gambar 16.19 Pengaturan Detail untuk Kustomisasi Ikon 

 

16.12 Tips 8: Menampilkan Isi Sel di Dalam Shape 

Prosedur untuk menampilkan isi sel di dalam sebuah shape adalah sebagai berikut: 

1. Tentukan teks yang akan ditampilkan di dalam salah satu sel 

2. Klik pada shape yang diinginkan 

3. Ketikkan referensi terhadap sel yang dibuat pada langkah 1. 

4. Atur tampilan dengan memilih font yang sesuai di tab Home. 

 



 

 

Gambar 16.20 Isi Sel di Dalam Shape 

 

16.13 Menambahkan Angka “0” Sebelum Angka Lainnya 

Jika kita menuliskan angka 007, maka secara otomatis Excel akan merubahnya menjadi angka 

7 saja tanpa awalan angka 0. Angka 0 selalu hilang jika berada di awal angka lainnya. Agar 

angka 0 muncul, tambahkan simbol kutip satu (‘) sebelum menulis angka 0 itu. Jadi, untuk 

menuliskan angka 007, pada sel di Excel kita tulisan ‘007 seperti tampak pada screenshot 

berikut ini. 

 

Dan hasilnya Excel tetap menyertakan angka 0 di belakang angka 7. 

 

Namun, permasalahannya adalah bagaimana jika angka-angka tersebut sudah tertulis. Sebagai 

contoh, misalnya saja kita memiliki tabel yang berisikan beberapa angka seperti berikut ini: 



 

 

Pada deretan angka tersebut, kita ingin menambahkan angka 0 di depannya, hingga hasil yang 

diharapkan adalah 001, 002, dan seterusnya. Bisa saja dengan menggunakan cara sebelumnya, 

yaitu dengan menambahkan simbol [‘], namun itu artinya kita harus mengetik ulang semua 

angka tersebut secara manual. Jika jumlahnya sedikit, tentunya tidak masalah. Namun, jika 

jumlahnya banyak, jelas sangat tidak efisien. Sebagai solusi, kita dapat menggunakan fasilitas 

format sel. Caranya sebagai berikut ini: 

Pada tabel tersebut, sorot atau blok sel A1 hingga A5. Lalu pada sel yang telah disorot tersebut, 

klik-kanan mouse, dan pada menu yang muncul klik Format Cells. Atau, cara cepatnya, 

gunakan keyboard shortcut [CTRL] + [1]. 

 

Pada kotak dialog Format Cells yang muncul, pastikan tab Number aktif. Lalu pada daftar 

Category pilih Custom. 

 

Pada bagian Custom ini, kita dapat mengatur format penulisan angka yang kita inginkan secara 

bebas. Excel juga telah menyediakan beberapa format penulisan angka yang umum digunakan. 

Namun untuk kasus tadi, kita harus menuliskan format sendiri. Caranya, klik pada kolom isian 

di bawah Type: lalu ketikan “00”# seperti tampak pada screenshot berikut ini: 



 

 

“00” Adalah karakter yang ingin kita tambahkan di depan angka dan simbol “#” mewakili 

angka yang sebelumnya sudah tertulis pada tabel. 

Klik tombol OK untuk menutup kotak dialog, dan hasil akhir yang kita dapatkan seperti pada 

screenshot berikut ini: 

 

Kita juga bisa menambahkan empat buah angka 0. Tinggal masuk kembali ke dalam kotak 

dialog Format Cells, lalu ganti karakter yang diapit tanda kutip dengan 0000. Jadi, yang 

tertulis pada bagian Type: adalah “0000”#. 

Kita juga bisa menambahkan karakter lain selain angka 0. Caranya, pada bagian Type: 

tersebut, ketikkan karakter yang akan kita masukkan. Misalnya, kita akan memasukkan ABC. 

Ketik “ABC-”#. Dan hasilnya sepert pada screenhot berikut ini: 

 

 

16.14 Contoh Konversi Data  

Bagaimana caranya mengubah koordinat GPS -6 54.623 ke -6.54623 pada Excel secara 

function atau rumus untuk diedit di map info hasil yang awalnya import dari map source? 



 

 

Jika data yang dihasilkan berada di satu cell, misalnya angka asli ada di C5, maka kita dapat 

mengubah data tersebut dengan menggunakan fungsi-fungsi Excel seperti: LEFT, RIGHT, 

FIND, SUBSTITUTE, dan VALUE. 

Fungsi LEFT dan RIGHT digunakan untuk mengambil data dengan dibantu fungsi FIND 

untuk menentukan posisi atau panjang data yang diambil dari cell. 

Langkahnya adalah sebagai berikut: 

1. Ambil angka depan dengan =VALUE(LEFT(C5,FIND(” “,C5))) dengan tujuan 

mengambil data bagian depan sampai dengan batas spasi antara angka -6 dengan 

54.623. Fungsi FIND digunakan untuk mencari jumlah char yang akan diambil dari 

data, yaitu dengan mencari posisi char spasi (” “) pada data, sehingga diperoleh char 

“-6 ”. Selanjutnya, ubah menjadi nilai dengan menggunakan Value. 

2. Ambil angka dari belakang sampai dengan batas spasi 

=SUBSTITUTE(RIGHT(C5,LEN(C5)-FIND(” “,C5)),”.”,”") dengan tujuan 

mengambil angka setelah spasi. LEN(C5)-FIND(” “,C5)) digunakan untuk mencari 

panjang char yang akan diambil, yaitu LEN(C5) atau panjang seluruh data dikurangi 

panjang data sampai dengan spasi (” “) dengan FIND(” “,C5). Selanjutnya, 

membuang tanda titik (.) pada data yang dihasilkan dengan menggunakan substitute 

titik (“.”) dengan blank (“”).  

3. Gabung kedua data yang dihasilkan dengan = VALUE(E5&”.”&F5). 

4. Copy untuk mengonversi data yang lainnya. 

Jika rumus tersebut dijadi satu maka akan menjadi: 

http://www.ziddu.com/download/7398270/KonversiMapInfoData.zip.html


 

=VALUE(VALUE(LEFT(C5,FIND(” 

“,C5)))&”.”&SUBSTITUTE(RIGHT(C5,LEN(C5)-FIND(” “,C5)),”.”,””)) 

Lihat lainnya di http://excel.aurino.com/2009/11/contoh-konversi-

data/#sthash.Dzo72ysZ.dpuf 

Daftar file pendukung: 

Untuk bagian What-If Analysis, file Excel pendukung ada di lokasi: 

http://peter.petra.ac.id/~petrus/Whatif.xlsx 

 

Untuk bagian Pivot Table, file Excel pendukung ada di lokasi:  

http://peter.petra.ac.id/~petrus/Pivot.xlsx 

 

Untuk bagian Advanced Chart, file Excel pendukung ada di lokasi: 

http://peter.petra.ac.id/~petrus/Chart.xlsx 
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